white screen on iphone (maybe iOS6 issue)

138 views
Skip to first unread message

MeiAestro

unread,
Sep 28, 2012, 6:50:53 AM9/28/12
to google-we...@googlegroups.com
Hey there,

I am quite in trouble as a mobile website which worked fine for months now only shows an empty white screen on my iPhone. I am just guessing this might be because of the new iOS 6.0 Does anybody of you has made similar experiences? The RootLayoutPanel is the basis of my page.

Thanks & kind regards!

MeiAestro

unread,
Sep 28, 2012, 10:23:17 AM9/28/12
to google-we...@googlegroups.com
Ok, now I am sure it is an iOS6 problem. It still works on older iOS. And I am also sure that it has to do something with the RootLayoutPanel. Everything is shown correctly when I use RootPanel, but then I cannot use the required onResize functionality.

Any ideas?

Milan Cvejic

unread,
Sep 28, 2012, 10:44:26 AM9/28/12
to google-we...@googlegroups.com
You can easily create your own Panel by extending ComplexPanel and attaching ResizeHandler

something like this:

Window.addResizeHandler(new ResizeHandler() {
for (Widget child : getChildren()) { if (child instanceof RequiresResize) { ((RequiresResize) child).onResize(); }
}

You should also implement all methods from RootPanel.

Best,
Milan

MeiAestro

unread,
Sep 28, 2012, 10:50:09 AM9/28/12
to google-we...@googlegroups.com
Thanks, I will try to build a workaround. Any ideas what might be the reason why it is not working anymore with ios6 ???

MeiAestro

unread,
Sep 28, 2012, 12:38:59 PM9/28/12
to google-we...@googlegroups.com
is there maybe a new user agent String required for ios6? I am using:
<set-property name="user.agent" value="safari,ie8,ie9,gecko1_8,opera">

Manuel Carrasco Moñino

unread,
Sep 29, 2012, 5:10:46 AM9/29/12
to google-we...@googlegroups.com
Maybe IOS6 issue about caching posts requests could be your problem, in the case you are doing a RPC/RF post to your web-server and you wait for a response before showing the initial screen of your app.

On Fri, Sep 28, 2012 at 6:38 PM, MeiAestro <JMAlb...@gmx.de> wrote:
is there maybe a new user agent String required for ios6? I am using:
<set-property name="user.agent" value="safari,ie8,ie9,gecko1_8,opera">

--
You received this message because you are subscribed to the Google Groups "Google Web Toolkit" group.
To view this discussion on the web visit https://groups.google.com/d/msg/google-web-toolkit/-/ijO15XkyDQgJ.

To post to this group, send email to google-we...@googlegroups.com.
To unsubscribe from this group, send email to google-web-tool...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/google-web-toolkit?hl=en.

MeiAestro

unread,
Oct 2, 2012, 5:47:58 AM10/2/12
to google-we...@googlegroups.com
it really seems to be a Ajax caching problem. I am loading the google maps v3 using the Ajaxloader-Package (http://gwt-google-apis.googlecode.com/svn/javadoc/ajaxloader/1.1/index.html). Unfortunately I have no clue where to change any header information.

I would appreciate any hints!

Thanks!

Reply all
Reply to author
Forward
0 new messages