GWT 2.8.0-SNAPSHOT jsinterop missing module

1335 views
Skip to first unread message

geek.m...@gmail.com

unread,
Dec 11, 2015, 5:08:01 PM12/11/15
to GWT Users

Hi, I'm using the GWT 2.8.0-SNAPSHOT along with the Mojo GWT plugin (same version). Been working fine all week, but today I suddenly get this error message when doing a build: 


[INFO] --- gwt-maven-plugin:2.8.0-SNAPSHOT:compile (default) @ ritual-designer-bs ---

[INFO] Loading inherited module 'com.mjeffw.gurps.ritualdesigner.RitualDesignerBS'

[INFO]    Loading inherited module 'com.google.gwt.core.Core'

[INFO]       Loading inherited module 'jsinterop.annotations.Annotations'

[INFO]          [ERROR] Unable to find 'jsinterop/annotations/Annotations.gwt.xml' on your classpath; could be a typo, or maybe you forgot to include a classpath entry for source?


Any ideas on how to solve this?

Thomas Broyer

unread,
Dec 11, 2015, 5:36:27 PM12/11/15
to GWT Users
Make sure your dependencies are up-to-date and all present in the classpath (there's a new com.google.jsinterop:jsinterop-annotations artifact that com.google.gwt:gwt-user depends on)

geek.m...@gmail.com

unread,
Dec 12, 2015, 11:06:48 AM12/12/15
to GWT Users
Everything is up-to-date - I have made no changes, except to do a new mvn install. I just did a Maven > Update project, and a mvn clean, followed by a mvn install, and its still broken.

Here's the content of my pom.xml:


 

<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
 
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">

 
<modelVersion>4.0.0</modelVersion>
 
<groupId>com.mjeffw.gurps.ritualdesigner</groupId>
 
<artifactId>ritual-designer-bs</artifactId>
 
<packaging>war</packaging>
 
<version>1.0-SNAPSHOT</version>
 
<name>Maven Archetype for GWT</name>

 
<properties>
   
<!-- Convenience property to set the GWT version -->
   
<gwtVersion>2.8.0-SNAPSHOT</gwtVersion>
   
<!-- GWT needs at least java 1.7 -->
   
<maven.compiler.source>1.8</maven.compiler.source>
   
<maven.compiler.target>1.8</maven.compiler.target>
   
<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
   
<bootstrapVersion>0.9.2</bootstrapVersion>
   
<maven-war-plugin.version>2.6</maven-war-plugin.version>
   
<webapp.directory>${project.build.directory}/${project.build.finalName}</webapp.directory>
 
</properties>

 
<dependencyManagement>
   
<dependencies>
     
<dependency>
       
<groupId>com.google.gwt</groupId>
       
<artifactId>gwt</artifactId>
       
<version>${gwtVersion}</version>
       
<type>pom</type>
       
<scope>import</scope>
     
</dependency>
   
</dependencies>
 
</dependencyManagement>

 
<dependencies>
   
<dependency>
     
<groupId>org.gwtbootstrap3</groupId>
     
<artifactId>gwtbootstrap3</artifactId>
     
<version>${bootstrapVersion}</version>
     
<scope>provided</scope>
   
</dependency>

   
<dependency>
     
<groupId>org.gwtbootstrap3</groupId>
     
<artifactId>gwtbootstrap3-extras</artifactId>
     
<version>${bootstrapVersion}</version>
     
<scope>provided</scope>
   
</dependency>

   
<dependency>
     
<groupId>com.google.gwt</groupId>
     
<artifactId>gwt-user</artifactId>
     
<scope>provided</scope>
   
</dependency>

   
<dependency>
     
<groupId>com.google.gwt.inject</groupId>
     
<artifactId>gin</artifactId>
     
<version>2.1.2</version>
   
</dependency>

   
<dependency>
     
<groupId>com.google.gwt</groupId>
     
<artifactId>gwt-servlet</artifactId>
     
<scope>runtime</scope>
   
</dependency>

   
<dependency>
     
<groupId>com.google.gwt</groupId>
     
<artifactId>gwt-dev</artifactId>
     
<scope>provided</scope>
   
</dependency>

   
<dependency>
     
<groupId>junit</groupId>
     
<artifactId>junit</artifactId>
     
<version>4.11</version>
     
<scope>test</scope>
   
</dependency>

   
<dependency>
     
<groupId>com.mjeffw.gwt</groupId>
     
<artifactId>gwt-utils</artifactId>
     
<version>1.0-SNAPSHOT</version>
   
</dependency>
 
</dependencies>

 
<build>
   
<!-- Output classes directly into the webapp, so that IDEs and "mvn process-classes" update them in DevMode -->
   
<outputDirectory>${project.build.directory}/${project.build.finalName}/WEB-INF/classes</outputDirectory>
   
<plugins>
     
<!-- Mojo's Maven Plugin for GWT -->
     
<plugin>
       
<groupId>org.codehaus.mojo</groupId>
       
<artifactId>gwt-maven-plugin</artifactId>
       
<version>${gwtVersion}</version>
       
<executions>
         
<execution>
           
<goals>
             
<goal>compile</goal>
             
<goal>test</goal>
             
<goal>generateAsync</goal>
           
</goals>
         
</execution>
       
</executions>

       
<!-- Plugin configuration. There are many available options, see gwt-maven-plugin documentation at codehaus.org -->
       
<configuration>
         
<runTarget>RitualDesignerBS.html</runTarget>
         
<hostedWebapp>${webapp.directory}</hostedWebapp>
         
<modules>
           
<module>com.mjeffw.gurps.ritualdesigner.RitualDesignerBS</module>
         
</modules>
       
</configuration>
     
</plugin>

     
<!-- Copy static web files before executing gwt:run -->
     
<plugin>
       
<groupId>org.apache.maven.plugins</groupId>
       
<artifactId>maven-war-plugin</artifactId>
       
<version>${maven-war-plugin.version}</version>
       
<executions>
         
<execution>
           
<phase>compile</phase>
           
<goals>
             
<goal>exploded</goal>
           
</goals>
         
</execution>
       
</executions>

       
<configuration>
         
<webappDirectory>${webapp.directory}</webappDirectory>
       
</configuration>
     
</plugin>

     
<plugin>
       
<groupId>org.apache.maven.plugins</groupId>
       
<artifactId>maven-compiler-plugin</artifactId>
     
</plugin>
   
</plugins>
 
</build>
 
 
<repositories>
   
<repository>
     
<id>sonatype-nexus-snapshots</id>
     
<url>http://oss.sonatype.org/content/repositories/snapshots</url>
     
<snapshots>
       
<enabled>true</enabled>
     
</snapshots>
     
<releases>
       
<enabled>false</enabled>
     
</releases>
   
</repository>
 
</repositories>
</project>



Any ideas on what is going on here would be appreciated!

geek.m...@gmail.com

unread,
Dec 12, 2015, 11:33:33 AM12/12/15
to GWT Users
I solve this issue myself by switching to gwt-2.8.0-beta1 and adding the declarations to my POM to use the 2.8.0-SNAPSHOT version of the plugin with a different version of GWT.

Thomas Broyer

unread,
Dec 12, 2015, 2:17:37 PM12/12/15
to GWT Users
Do you have $M2_HOME/repository/com/google/jsinterop/jsinterop-annotations/jsinterop-annotations-*-sources.jar in the classpath? (as should be seen in the Maven error output)

Ali Akhtar

unread,
Dec 20, 2015, 8:11:30 AM12/20/15
to GWT Users
I'm also encountering this issue with sandbox. The /home/ali/.m2/repository/com/google/jsinterop/jsinterop/1.0.0-SNAPSHOT contains only pom files, no jars. I'm attempting to upgrade - anyone know which maven repository contains the snapshot version of the maven plugin, or does it have to be installed via manual compile (Yay - not)?

Ali Akhtar

unread,
Dec 20, 2015, 8:11:45 AM12/20/15
to GWT Users
sandbox = snapshot

Thomas Broyer

unread,
Dec 20, 2015, 11:39:12 AM12/20/15
to GWT Users


On Sunday, December 20, 2015 at 2:11:30 PM UTC+1, Ali Akhtar wrote:
I'm also encountering this issue with sandbox. The /home/ali/.m2/repository/com/google/jsinterop/jsinterop/1.0.0-SNAPSHOT contains only pom files, no jars.

This is normal: the JAR is com.google.jsinterop:jsinterop-annotations.
com.google.jsinterop:jsinterop is only a parent POM (just like com.google.gwt:gwt and com.google.web.bindery:requestfactory)

Ali Akhtar

unread,
Dec 20, 2015, 11:43:10 AM12/20/15
to Google Web Toolkit
I'm still getting the same error as the OP on snapshot though. But switching to beta fixed it - however I can't find the maven plugin's snapshot / beta version on any repo, I had to compile / install it locally. Is it on any repos?


--
You received this message because you are subscribed to a topic in the Google Groups "GWT Users" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/google-web-toolkit/mv0RAmAXoEo/unsubscribe.
To unsubscribe from this group and all its topics, send an email to google-web-tool...@googlegroups.com.
To post to this group, send email to google-we...@googlegroups.com.
Visit this group at https://groups.google.com/group/google-web-toolkit.
For more options, visit https://groups.google.com/d/optout.

Reply all
Reply to author
Forward
0 new messages