What setting controls whether Eclipse is building the development version or not?

45 views
Skip to first unread message

mmo

unread,
Aug 24, 2021, 10:02:32 AMAug 24
to GWT Users
I somehow destroyed my Eclipse setup for GWT applicaiton debugging - could some kind soul please help me to get going again?

Before I had set up my GWT project using a local Tomcat server such that I was able to run and debug it using:

First starting the CodeServer (via right-click on the GWT project --> "Run As" --> "GWT Development Mode") on localhost:9876.
Second: starting Tomcat (via right-click on the GWT project --> "Run As" --> "Run on Server") on localhost:8080

This had worked out-of-the-box and created and started up the application in development mode where it fetches the <app>.nocache.js code from the code server, but directs all HTML, CSS and especially also all RPC-requests to Tomcat's application port. With that I had been able to start, breakpoint and debug my GWT application (though the server side code only).

Trying to get this setup to also provide the sourcemaps and allow me to debug also client side code using Chrome and the SDBG plugin I somehow destroyed that working setup and I haven't understood, yet, why this is not working anymore:

While I can still start the code server as described above starting up the application on Tomcat downloads an index.html file-version that tries to fetch the <myapp>.nocache.js file from Tomcat as well (i.e. using the URL <script type="text/javascript" src="rwtool/rwtool.nocache.js"></script> in the index.html-file). 

That of course doesn't work (that file needs to be fetched from the code-server's port!) and so my GWT applications (or rather its welcome page) just hangs and nothing happens.

I have no clue what I did or destroyed or disabled so that this doesn't work anymore.
What do I need to do to convince Eclipse to build the development version again like it used to?

mmo

unread,
Aug 24, 2021, 5:23:13 PMAug 24
to GWT Users
Issue solved!
Probably due to my experimenting (among them the re-creation of a Server-definition) the CodeServer's launcherDir-path (<project>\.metadata\.plugins\org.eclipse.wst.server.core\tmp0\wtpwebapps\rwtool-web) and the WTP deploy-path for Tomcat: (-Dwtp.deploy="U:\Documents\eclipse\workspace_KStA_RW-Tool\.metadata\.plugins\org.eclipse.wst.server.core\tmp1\wtpwebapps) had diverged from each other (Note the "tmp0" vs. "tmp1" in the paths).
Once I had realized and fixed this, everything came back to normal!

Apologies for the bandwidth used...

Craig Mitchell

unread,
Aug 25, 2021, 3:18:31 AMAug 25
to GWT Users
Glad you found your issue.  I'm always forgetting to set the "-launcherDir" on the code server on a fresh install.  :)

Another thing that trips me up, is when I do a "GWT Compile Project" (because I want to deploy my site to test/prod), after I've done that, when I start up my code server again, I have to remember, in Eclipse, to publish my web server.  This triggers the web server to realise that the xxx.nocache.js has been changed after the compile was done.

If I don't do that, when I start my web server, it still has the compiled xxx.nocache.js, and then uses the compiled JS, not the code server.

Interested to know if this happens with Tomcat, or it's just a quirk of the Google App Engine web server.

Reply all
Reply to author
Forward
0 new messages