gwt 2.5 - Elemental -> Browser compatibility question ?

392 views
Skip to first unread message

regnoult axel

unread,
Jun 29, 2012, 4:18:54 PM6/29/12
to google-we...@googlegroups.com
Hello,

Reading the official documentation  :

it is said that :

 Using these draft-spec extensions may result in code that doesn't work on Firefox, Opera, or IE. 

My question, is that, for my current project that will be in production in 1 or 2 month, should I use Elementals ? I need a compatibility with IE 7 and greater versions, Chrome and Firefox.

I also did found a lot of documentation about elemental (neither how to use it, ..., neither inside the javadoc)

Thanks you.

Thomas Broyer

unread,
Jun 29, 2012, 6:00:27 PM6/29/12
to google-we...@googlegroups.com


On Friday, June 29, 2012 10:18:54 PM UTC+2, regnoult axel wrote:
Hello,

Reading the official documentation  :

it is said that :

 Using these draft-spec extensions may result in code that doesn't work on Firefox, Opera, or IE. 

My question, is that, for my current project that will be in production in 1 or 2 month, should I use Elementals ?

1 or 2 months? I wouldn't use too much experimental stuff then (except SuperDevMode, but that's an experimental dev tool, it's not part of the final app)
 
I need a compatibility with IE 7 and greater versions, Chrome and Firefox.

IE is a no-go for Elemental. IE9 might be envisaged, if you stick to the very basics (but then you'd better use com.google.gwt.dom, HTMLPanel/RenderablePanel and CellWidget).
 
I also did found a lot of documentation about elemental (neither how to use it, ..., neither inside the javadoc)

Elemental landed just 2 (or was it 3) weeks ago, and then Ray had to concentrate on I/O, and the rest of the team on shipping that 2.5.0 RC1; it's definitely too early to make use of Elemental other than trying it out and/or willing to help make it better.

raja...@gmail.com

unread,
Jun 30, 2012, 12:36:06 AM6/30/12
to google-we...@googlegroups.com
Sent from BlackBerry® on Airtel

From: Thomas Broyer <t.br...@gmail.com>
Date: Fri, 29 Jun 2012 15:00:27 -0700 (PDT)
Subject: Re: gwt 2.5 - Elemental -> Browser compatibility question ?
--
You received this message because you are subscribed to the Google Groups "Google Web Toolkit" group.
To view this discussion on the web visit https://groups.google.com/d/msg/google-web-toolkit/-/x-HcyHbNifcJ.
To post to this group, send email to google-we...@googlegroups.com.
To unsubscribe from this group, send email to google-web-tool...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/google-web-toolkit?hl=en.
Reply all
Reply to author
Forward
0 new messages