GWT 2.2 and maven

150 views
Skip to first unread message

Jakub Grabowski

unread,
Feb 13, 2011, 4:27:26 AM2/13/11
to Google Web Toolkit
Do you have any idea when GWT 2.2.0 will be available in maven central
repo? Currently projects generated with -maven option don't work,
because dependencies cannot be retrieved. Is there any other repo
containing maven artifacts for GWT before they're published to central
repo?

Thanks for help.

Regards,
Jakub Grabowski
Perfectsource Sp. z o.o.
http://www.perfectsource.pl

David Chandler

unread,
Feb 13, 2011, 2:54:56 PM2/13/11
to google-we...@googlegroups.com
Maven Central push should come out Monday. Until then, you can try it out from the staging repo:


--
You received this message because you are subscribed to the Google Groups "Google Web Toolkit" group.
To post to this group, send email to google-we...@googlegroups.com.
To unsubscribe from this group, send email to google-web-tool...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/google-web-toolkit?hl=en.




--
David Chandler
Developer Programs Engineer, Google Web Toolkit
w: http://code.google.com/
b: http://googlewebtoolkit.blogspot.com/
t: @googledevtools

Diego Lovison

unread,
Feb 14, 2011, 6:03:49 AM2/14/11
to Google Web Toolkit
how I can set to maven work with 2.2?

<repository>
<id>????</id>
<name>???</name>
<url>????</url>
</repository>

David Chandler

unread,
Feb 15, 2011, 6:18:06 AM2/15/11
to google-we...@googlegroups.com
It's in Maven Central now, no custom repo needed.

See the Expenses sample POM for correct declaration of gwt-maven-plugin that works with 2.2.0:


/dmc

George Moschovitis

unread,
Feb 15, 2011, 6:30:13 AM2/15/11
to google-we...@googlegroups.com
Great!

What about compatible versions of Guice/GIN?

-g.

David Chandler

unread,
Feb 15, 2011, 10:31:08 AM2/15/11
to google-we...@googlegroups.com
It's up to the GIN and Guice open source projects when / if they'll push new maven artifacts. I'm sure those projects would be glad for volunteers.

/dmc

--
You received this message because you are subscribed to the Google Groups "Google Web Toolkit" group.
To post to this group, send email to google-we...@googlegroups.com.
To unsubscribe from this group, send email to google-web-tool...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/google-web-toolkit?hl=en.

Thomas Broyer

unread,
Feb 15, 2011, 12:22:23 PM2/15/11
to google-we...@googlegroups.com
A GIN 1.5 version should be out soon (requiring Guice 3.0rc2)

David Chandler

unread,
Feb 15, 2011, 6:14:37 PM2/15/11
to google-we...@googlegroups.com
Thanks, Thomas. I was just getting ready to post that, as the GWT team has been discussing it with Peter Schmitt once we all realized the problem. Sorry to GIN users for the accidental breakage.

/dmc

On Tue, Feb 15, 2011 at 12:22 PM, Thomas Broyer <t.br...@gmail.com> wrote:
A GIN 1.5 version should be out soon (requiring Guice 3.0rc2)

--
You received this message because you are subscribed to the Google Groups "Google Web Toolkit" group.
To post to this group, send email to google-we...@googlegroups.com.
To unsubscribe from this group, send email to google-web-tool...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/google-web-toolkit?hl=en.
Reply all
Reply to author
Forward
0 new messages