porting older app from 2.5.0 to 2.8.2

300 views
Skip to first unread message

Blaze

unread,
Aug 11, 2019, 3:14:35 PM8/11/19
to GWT Users
Hi all,

I was wondering if some one can help me on this one...
I have a older app which uses gxt.2.2.5-gwt22.jar, and when compiling with gwt 2.8.2 Im getting some errors like this:

 [ERROR] Errors in 'jar:file:/xxxxx/gxt-2.2.5-gwt22.jar!/com/extjs/gxt/ui/client/widget/form/ListField.java'
     [java]                [ERROR] Line 322: The method append(boolean) is ambiguous for the type StringBuffer


  [ERROR] Errors in 'jar:file:/xxxxxx/gxt-2.2.5-gwt22.jar!/com/extjs/gxt/ui/client/widget/form/HtmlEditor.java'
     [java]                [ERROR] Line 548: Type mismatch: cannot convert from com.google.gwt.dom.client.Element to com.google.gwt.user.client.Element
     [java]          [ERROR] Hint: Check the inheritance chain from your module; it may not be inheriting a required module or a module may not be adding its source path entries properly
    

Im guessing other gxt.jar file needs to be used, which adopts the small changes.
I searched on the net, found some but not sure if this are the one to go with. e.g a jar called gxt-2.3.1a-gwt22.jar, also this one on git: https://github.com/bedatadriven/gxt

Can some one give me some insides on this one, that would be great!!

Tnx in advance,
Blaze

        

Ignacio Baca Moreno-Torres

unread,
Aug 12, 2019, 2:38:37 AM8/12/19
to google-we...@googlegroups.com
I'm not sure how difficult is to make it compile with GWT 2.8, if even possible, but officially only GXT 4 is compatible with GWT 2.8:

--
You received this message because you are subscribed to the Google Groups "GWT Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to google-web-tool...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/google-web-toolkit/8986b211-a13b-4e6c-85b7-6d8eaecc57b6%40googlegroups.com.

Frank Hossfeld

unread,
Aug 12, 2019, 5:14:14 AM8/12/19
to GWT Users
Just adding the version matrix link to Ignacio's answer:

Blaze

unread,
Aug 12, 2019, 6:37:52 AM8/12/19
to GWT Users
Hi,

first thanks for the reply. 

Well actually gxt 2 should not work with gwt 2.5 also, but this gxt-2.2.5-gwt22.jar its adopted to work.
This is more of a question for Colin Alworth I guess :) 

I was thinking that somebody has done the migration already. 
There are a lot of older apps that used gxt2, and now want to use maybe some of the benefits of the new gwt versions e.g 2.8...

Frank Hossfeld

unread,
Aug 12, 2019, 7:09:01 AM8/12/19
to GWT Users
Not sure, if it will work with GWT 2.8, but I would give it a try:

RT

unread,
Oct 13, 2021, 4:44:56 PMOct 13
to GWT Users
Were you able to resolve the error in ListField?  I have the same error trying to get GWT 2.8.2 working with GXT 2.3.1a.
Reply all
Reply to author
Forward
0 new messages