Maps JavaScript API Version Update

924 views
Skip to first unread message

Yong Su

unread,
Nov 16, 2023, 1:12:58 AM11/16/23
to google-maps-js...@googlegroups.com
The Maps API v3 team has completed the quarterly version change today, here are the new versions:

Weekly channel is now serving 3.55
Quarterly channel is serving 3.54
Exact version numbers can be specified as v=3.55, v=3.54, v=3.53, or v=3.52

Version 3.51 is decommissioned.

For most customers this will be a completely invisible change. However, since v3.54.1 we
upgraded Maps JavaScript API to support ECMAScript 2020 natively, meaning that less code is polifilled by taking advantage of browser built-in features (see more details here).

Please also check what browsers are supported here. If your Map cannot be loaded due to this update, as a temporary workaround, you can switch your app to use v3.53, directly while loading Maps JS API. But please keep in mind that 3.53 will be removed in May next year (see our release schedule here)

If you don't specify a version (or request a retired version), you will be served a default version, which depending on your key configuration will be either 3.54 or 3.55. But a developer specified version will always be honored and served when requested when it's an existing version.


For more information about Maps API versioning, see:

https://developers.google.com/maps/documentation/javascript/versions


To report issues with any version of the API, see: https://issuetracker.google.com/savedsearches/558438

Reply all
Reply to author
Forward
0 new messages