Can't run google earth plugin

539 views
Skip to first unread message

W. H Lau

unread,
Apr 29, 2015, 9:28:20 AM4/29/15
to google-earth-...@googlegroups.com
always show the attached message, when I go to GEFS web site, even download and install google earth plugin and google earth respectively.
DL_googleearth_plugin.jpg

josh258

unread,
May 3, 2015, 10:02:52 AM5/3/15
to google-earth-...@googlegroups.com
The Google Earth plugin has been deprecated, but has already stopped working for many browsers including Google Chrome. The error messages is a default message for when the plugin fails to load. For now, Chrome has a work around, but these require the user to change Chrome settings. Below is the supported browser page from Google (notice Chrome support stops at 39; current version around 42) and Google Earth Blog's current work around for Chrome. As of May 3, Firefox asks user if they want to load the Plugin, Chrome was the same way until version 42. IE has needed a compatibility <meta tag> since IE10. 
Reply all
Reply to author
Forward
0 new messages