Uploading a folder to a newly created Bucket

17 views
Skip to first unread message

Gregory Carlson

unread,
May 31, 2021, 10:11:31 AMMay 31
to google-cloud-storage-discuss
I requested that a folder be uploaded to a bucket
from my local machine.  The folder contains more
than 10 directories, but only 3 directories were
partially uploaded.

I deleted the bucket and tried several more times,
each with the same result.

Any advice would be appreciated.

Thank you.

Imran Khan

unread,
May 31, 2021, 12:29:13 PMMay 31
to google-cloud-storage-discuss
Hi Gregory,

Google Cloud Storage won't upload the folders if these are empty, please check if the folders are empty. 

Secondly,  there is a maximum size limit of 5 TiB for uploads. 

If you have Cloud SDK set up, you can try using the gsutil -m cp .. command to transfer the files to GCS bucket.

Thanks,
IKhan

Jim Garner

unread,
Aug 3, 2021, 11:49:02 AMAug 3
to google-cloud-storage-discuss
Perhaps associated with this... I am trying to UPLOAD many individual files within a folder to the cloud.
They are smaller kmz files used in a Superoverlay for Google Earth.
Whether I try to upload a folder of them, or create the folder then upload the files, I almost always get an "Aw Snap!"  and it times out, or I keep getting "Wait or Exit" dialogs.
So, is there a limit to uploading?

Thanx!
Reply all
Reply to author
Forward
0 new messages