Cannot deploy app - just spins trying to load deployment

1166 views
Skip to first unread message

PirateSteve Brown

unread,
Dec 28, 2021, 9:32:31 PM12/28/21
to Google Apps Script Community
Have made hundreds of updates and  deployments using the new editor to a simple webapp.  Suddenly today, after making small change to script in form.html and saving, I am  unable to create a new deployment...I just get a popup screen with a spinning circle saying "Loading deployment..." ...and it just sits there and spins...no message, no error, nada.  

Have tried restoring an older known working revision file, using a different browser, restarting my PC.  Still just spins trying to load...  When I tried publish with the old editor it did not include the HTML except the bare form elements...all else, background, text, image, etc., just not there.

Realize this maybe vague, but don't know how else to describe or go forward.  Noob here that built this by cobbling together stuff and experimenting.  Any help greatly appreciated.  Links, code, etc., gladly supplied if that helps.

Thanks for help,
Steve

PirateSteve Brown

unread,
Dec 29, 2021, 10:42:40 AM12/29/21
to Google Apps Script Community
UPDATE-SOLVED.  I learned that the /dev and /exec actually have different script IDs, so just changing the final term to exec does not really point to a production version.  This caused problems with embedding the code in an iframe.

Final solution that seems to be working is I created a new app script project, copied my code.gs and form.html code into the new project and, viola, the new editor Deploy works, the code works, the /exec works, the iframe now works across browsers.   Apparently something got hosed in my original Google drive app script project.  New project, with exact same code, seems to be working fine.   Whew.

PirateSteve Brown

unread,
Dec 29, 2021, 10:42:51 AM12/29/21
to Google Apps Script Community
Figured out a way around it.  It does not appear to be problem with the code.

Use the old editor publish function, create a new version and click Update.
If you copy the updated url and paste into browser, the html will be missing as noted in original question. 
So do not copy the provided url, instead, click "Test your code".  This will open a browser tab and execute your code as a web app, including  the html bits; it words as it should.  
The url  in the new tab created by the "Test your code" ends with "/dev".  Just change this to "/exec" and apparently you will then be executing a new production deployment of your app, with all the bits working.

Don't know what happened with the new editor deploy function as described in original question,  I still just get spinning circle. But using this method with the old editor got me back to being able to make changes to my code and publish/deploy the new version.

Strange experience - hope this helps somebody else.

Steve

On Tuesday, December 28, 2021 at 9:32:31 PM UTC-5 PirateSteve Brown wrote:

Alan Wells

unread,
Dec 29, 2021, 11:21:26 AM12/29/21
to Google Apps Script Community
Thank you for posting your findings.

Philippe Laurent

unread,
Aug 1, 2022, 9:24:08 PM8/1/22
to Google Apps Script Community
You have saved my project sir, thank you.

ASI IT Application

unread,
Nov 23, 2022, 3:21:34 AM11/23/22
to Google Apps Script Community
Now as the old editor has been stopped.

Is there any method to reset this behaviour.  
I could only solve this by making a copy of the code script.

Does any one know a better solution ?

Amibroker Plugins

unread,
Dec 31, 2022, 11:46:12 AM12/31/22
to Google Apps Script Community
I am also interested in this. After deploying the 201st version the Deployment manager got unaccessible.
It is very important for me to keep the URL of the deployed application,
so creating a new Apps Script is not the best solution for me :(
Any ideas?

CBMServices Web

unread,
Dec 31, 2022, 12:41:23 PM12/31/22
to google-apps-sc...@googlegroups.com
At 201 versions, I would say you are updating this too many times. One trick to reduce the number of updates you need to do is to have minimal code in the file where the webapp is and put the majority of the code in a separate script file. Link the two by using a library. This way all changes in library do not require you to redeploy the webapp.

On the new editor, to deploy a new version of the webapp and not change the url, do the following:

- click on deploy, but choose manage deployment.
- click to select the previous deployment from list shown of what you have deployed previously, then click the edit icon which appears on top left side of it.
- click top box and choose new version.
- click second box and add in any description(optional)
- save.

That will deploy the new version of the webapp without changing the url.

--
You received this message because you are subscribed to the Google Groups "Google Apps Script Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to google-apps-script-c...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/google-apps-script-community/43856628-f0ca-41a2-ab19-56a47c5aca11n%40googlegroups.com.

Adam Gosnell

unread,
Jan 17, 2023, 1:33:51 AM (9 days ago) Jan 17
to Google Apps Script Community
I had this problem. I was using Firefox. Switched to Microsoft Edge, worked no sweat, and now I can manage Deployments from Firefox.
Reply all
Reply to author
Forward
0 new messages