All New Libraries Break Web Apps

48 views
Skip to first unread message

Christopher Webster

unread,
Feb 21, 2024, 11:26:27 AMFeb 21
to Google Apps Script Community
GAS just started throwing strange and deabilitating errors.  Starting a couple of days ago I found that when I added a new library to a project with a web app, the web app will break and won't load.  This generic error shows up in the console:

Google Docs encountered an error. Please try reloading this page, or coming back to it in a few minutes.

I have been doing extensive testing over the last few days and discovered:
  • Just the presence of the library with no references in the code is all that is required to cause the web app to fail.
  • I can call functions from the library in the editor without an issue.
  • New Web Apps also fail with the same error unless scoped to myself only
As can be assumed, this is a terrible isssue for our company and bringing development to a halt.  My only guess is that Google changed an internal permission setting and created this bug.  

Is anyone else having issues?  Does anyone have a potential solution?


Christopher Webster

unread,
Feb 21, 2024, 12:32:57 PMFeb 21
to Google Apps Script Community
So Jesse McCabe's recent post about head deployments reminded me that libraries default to head deployment and I forgot to check that.  

Head deployment is the issue. The libraries work fine when set to a version number but now break web apps when the head is deployed.
Reply all
Reply to author
Forward
0 new messages