Custom function #NAME or Loading... error

148 views
Skip to first unread message

Adrian Moisii

unread,
Feb 10, 2024, 11:43:59 AMFeb 10
to Google Apps Script Community
Since a couple of weeks ago our editor add-on custom functions started to show the #NAME error or are stuck in Loading... Everything worked fine until that moment.
Even though the #NAME error is shown (with the message 'unknown function'), if I click in the cell, the function parameters are correctly displayed. Refreshing the sheet doesn't fix the issue, but any change in the sheet (adding/deleting rows/columns or adding some text in any cell) fixes the issue in all sheets. Immediately reopening the sheet works fine, but when reopening after a few minutes the #NAME error is present again.

I was able to reproduce the issue with the simple DOUBLE custom function, in a blank spreadsheet (see screenshot).

Any idea why this is happening? Looks like a recently introduced Google bug.

Screenshot 2024-02-10 094752.pngScreenshot 2024-02-10 095019.png
Message has been deleted

Rio

unread,
Feb 25, 2024, 1:24:28 AMFeb 25
to Google Apps Script Community
I am having the same problem. A simple function works when creating and testing. Then, after "some" time it become invalid with sheets showing "Unknown Function".

Rio

unread,
Feb 25, 2024, 1:47:14 AMFeb 25
to Google Apps Script Community
This seems to have worked for me:
  • In ScriptEditor go to Settings Settings 
  • Copy Script ID
  • In ScriptEditor got to Editor
  • Click the + next to Libraries
  • Paste the Script ID and click Look up
Hope it works for you too!

Reply all
Reply to author
Forward
0 new messages