Keep losing authorized scopes, forced to recreate oauth after ~1 hour

27 views
Skip to first unread message

Randy

unread,
Jan 26, 2022, 12:06:32 PMJan 26
to GAM for Google Workspace
I'm setting up a new GAMADV-XTD3 project on a new server to be used by a headless account for some automation. After getting everything setup, it works for a while. But after about an hour, I get the following error when attempting something like a "gam whatis" command:

"ERROR: There are no scopes authorized for the Directory API"

I thought I might need to make the service account an owner of the project in the IAM & Admin section of the Google Cloud Platform console, but that didn't seem to help.

Any thoughts on what could be causing this or where I could find some logging that would show what's happening? I've never had this issue when setting up GAM for my own use with my own account instead of a headless account.

Ross Scroggs

unread,
Jan 26, 2022, 12:22:35 PMJan 26
to google-ap...@googlegroups.com
Randy,

Contact me directly via Meet/Zoom.

--
You received this message because you are subscribed to the Google Groups "GAM for Google Workspace" group.
To unsubscribe from this group and stop receiving emails from it, send an email to google-apps-man...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/google-apps-manager/469cf90a-b62f-4e9d-bebf-1e682eeb4ccbn%40googlegroups.com.

Temple Rodgers

unread,
May 16, 2022, 4:07:23 AM (8 days ago) May 16
to GAM for Google Workspace
I'm getting the same thing ... a command ran perfectly well on Saturday and now, Monday morning, I get the same error message. How was it resolved?
It's a Windows server, it hasn't been rebooted or logged out.
thank you

Reply all
Reply to author
Forward
0 new messages