ScriptError: Service error: Spreadsheets

2100 views
Skip to first unread message

pi...@smartyou.pl

unread,
Mar 30, 2018, 4:52:09 AM3/30/18
to google-analytics-spreadsheet-add-on
Hi, 

Is there any technical issue with GA addon? We're getting this kind of error: 

ScriptError: Service error: Spreadsheets



Does anyone have similar problem? 

Sjoerd H

unread,
Mar 30, 2018, 7:23:39 AM3/30/18
to google-analytics-spreadsheet-add-on
Yes I have. All reports give me this error.


Op vrijdag 30 maart 2018 10:52:09 UTC+2 schreef Piotr Stryjniak:

a.klaa...@gmail.com

unread,
Mar 30, 2018, 7:43:09 AM3/30/18
to google-analytics-spreadsheet-add-on
Yes I have the same issue :-(
Message has been deleted
Message has been deleted

r...@uspmotorsports.com

unread,
Mar 30, 2018, 3:26:45 PM3/30/18
to google-analytics-spreadsheet-add-on
Same here - any ETA or resolutions anyone has found? 

Eric Langenberg

unread,
Mar 30, 2018, 3:31:45 PM3/30/18
to google-analytics-spreadsheet-add-on
You can 
  • copy the report
  • run the report again
  • get a *new* error message, which creates a new report configuration tab
  • copy the exact same values from the old report configuration tab to the new one
  • run the report again
Obviously not a great fix.  Hopefully Google will actually fix what appears to be a bug.  Haven't heard anything about ETA's.

r...@uspmotorsports.com

unread,
Mar 30, 2018, 3:36:18 PM3/30/18
to google-analytics-spreadsheet-add-on
Thanks Eric - tried that. Problem is once the report is queued to run again in an hour, same issue. 
Hopefully there's a fix soon for sure. Seems to be a growing issue. 

My report pulls in GA data, configures it in the format I need to use Zapier to send messages to Slack. Pretty nice setup all things considered, but when this happens it's not exactly ideal or bulletproof. 

Eric Langenberg

unread,
Mar 30, 2018, 4:00:25 PM3/30/18
to google-analytics-spreadsheet-add-on
Ah -- good to know.  More reason to hope for a fix soon.

lisak...@gmail.com

unread,
Mar 30, 2018, 5:12:27 PM3/30/18
to google-analytics-spreadsheet-add-on
I am having the same issue, happened after I tried out the filters, but even after I deleted the filters the error remains. Really need a fix for this Google, my project deadline is being messed up.

r...@uspmotorsports.com

unread,
Mar 31, 2018, 8:52:15 AM3/31/18
to google-analytics-spreadsheet-add-on
Anyone have success yet? Still having issues here...

c2ca...@gmail.com

unread,
Mar 31, 2018, 1:06:35 PM3/31/18
to google-analytics-spreadsheet-add-on
OH MY GOD
I have this problem too
ScriptError: Service error: Spreadsheets

I also can't create a new report! 

It's really a big bug! 

r...@uspmotorsports.com於 2018年3月31日星期六 UTC+8下午8時52分15秒寫道:
Message has been deleted

r...@uspmotorsports.com

unread,
Apr 1, 2018, 12:18:18 PM4/1/18
to google-analytics-spreadsheet-add-on
Hey @Google... this is really starting to impact us! Are you listening? (worth a shot right?)

Any updates anywhere? I have similar reports running under other accounts with zero issues... so something is up and it's not wide-spread from what I can tell. 


On Friday, March 30, 2018 at 4:52:09 AM UTC-4, Piotr Stryjniak wrote:

jeffn...@gmail.com

unread,
Apr 1, 2018, 8:43:17 PM4/1/18
to google-analytics-spreadsheet-add-on
I am having the same issue – the scheduled reports via the GA add on did not auto run at the designated time (1st day of the month) and attempts to manually run the reports resulted in a fail with same ScriptError: Service Error: Spreadsheets issue. It would really be nice to have an ETA from @Google on a fix.

Russell Ackner

unread,
Apr 1, 2018, 9:03:19 PM4/1/18
to jeffn...@gmail.com, google-analytics-spreadsheet-add-on
Well I bit the bullet and re-created my work (with a pretty extensive array formula with a few nested if statements) and behold - everything runs perfectly. 

I think it may be an issue with the v4 API - so it took 10 mins to literally cut and paste everything into a new sheet, delete old one and rename new one. Connect Zapier and boom - worked.

Was looking for a quick Google resolution but I had to take it upon myself. Good luck everyone. 

On Sun, Apr 1, 2018 at 8:43 PM <jeffn...@gmail.com> wrote:
I am having the same issue – the scheduled reports via the GA add on did not auto run at the designated time (1st day of the month) and attempts to manually run the reports resulted in a fail with same ScriptError: Service Error: Spreadsheets issue. It would really be nice to have an ETA from @Google on a fix.

--
You received this message because you are subscribed to a topic in the Google Groups "google-analytics-spreadsheet-add-on" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/google-analytics-spreadsheet-add-on/GVDlG9IjO_Q/unsubscribe.
To unsubscribe from this group and all its topics, send an email to google-analytics-spread...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/google-analytics-spreadsheet-add-on/3ce96807-3e5a-47a2-bcb4-f02d83b75653%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
--

minamoto china

unread,
Apr 1, 2018, 11:29:43 PM4/1/18
to google-analytics-spreadsheet-add-on
I have this problem too.

2018年3月30日金曜日 17時52分09秒 UTC+9 Piotr Stryjniak:

Jun Obana

unread,
Apr 2, 2018, 4:53:41 AM4/2/18
to google-analytics-spreadsheet-add-on
Yes I have. Some of my reports give me this error and someone is worked.



2018年3月30日金曜日 17時52分09秒 UTC+9 Piotr Stryjniak:
Hi, 

Ángela Sanz

unread,
Apr 2, 2018, 6:45:34 AM4/2/18
to google-analytics-spreadsheet-add-on
Hi all, 

I have the same issue in some of my reports. 

I tried your solution Eric, but it does't work for me, I got the same ScriptError in the new one. 

I hope Google fix it or at least they give us a solution soon. 

Thank you, 
Ángela

Benjamin Voran

unread,
Apr 2, 2018, 10:16:22 AM4/2/18
to google-analytics-spreadsheet-add-on
Same issue, hoping for a fix soon!
Message has been deleted

ph.ga.r...@gmail.com

unread,
Apr 2, 2018, 10:50:27 AM4/2/18
to google-analytics-spreadsheet-add-on
I have approximately 30 reports that are experiencing this issue. What seems to work for me is 
1) Duplicate the Report Configuration tab, 
2) Delete the remaining Report Configuration tab (not the duplicate)
3) Setup a new Report Configuration via Add-ons/Create New Report. 
4) Then just copy the cells from the duplicated report configuration tab from step 1 - up to row 11 (via copy and paste)
5) Run the report again. 

oscar....@kwantyx.com

unread,
Apr 2, 2018, 11:27:37 AM4/2/18
to google-analytics-spreadsheet-add-on
Awesome solution. I had some slides linked to my report, so creating a new one was going to be problematic. Thanks!

Message has been deleted
Message has been deleted
Message has been deleted

Andy Sperry

unread,
Apr 2, 2018, 2:07:39 PM4/2/18
to google-analytics-spreadsheet-add-on
Yes, I have the same problem on all 8 reports I have built. I cannot successfully run any of them. I have tried everything mentioned in this thread. One solution looks like it works but after running one time successfully the failure returns on subsequent runs.

Matt Girard

unread,
Apr 2, 2018, 2:24:16 PM4/2/18
to google-analytics-spreadsheet-add-on
Same here for me. I cannot run any of my reports as long as they have more than 5 tabs.

Amar Maktal

unread,
Apr 2, 2018, 3:51:03 PM4/2/18
to google-analytics-spreadsheet-add-on
This worked for me. I have more than 5 tabs in some sheets.

1) I started anew with a blank workbook and added a new Report Configuration. 

2) I copied that report configuration sheet to my problematic workbook and moved over the settings.

3)  renamed the sheets appropriately

4) ran report and it worked for me.

It looks like the default Report Configuration has changed slightly. Also, I had added some additional rows on my original Report Configuration which I removed.

Andy Sperry

unread,
Apr 2, 2018, 6:16:52 PM4/2/18
to google-analytics-spreadsheet-add-on
I tested this on one of my Sheets with 12 reports. Worked like a charm.  I would prefer an actual Google fix to the add-on, but this does get me out of a bind.

jeffn...@gmail.com

unread,
Apr 3, 2018, 9:02:08 PM4/3/18
to google-analytics-spreadsheet-add-on
Sometimes just chilling for a couple of days helps. Or maybe somebody somewhere got back from Easter and managed to adjust something.

In any event I now seem to be able to manually run reports, and they work. Which wasn't happening two days ago. Hopefully my 1st-of-the-month scheduled reports will resume auto running on May 1.

Ángela Sanz

unread,
Apr 4, 2018, 6:31:46 AM4/4/18
to google-analytics-spreadsheet-add-on
Hi all, 

It seems they fixed it!

I ran the reports as usual and it worked.

Andy Sperry

unread,
Apr 4, 2018, 8:20:35 AM4/4/18
to google-analytics-spreadsheet-add-on
Yes, I agree with the other comments - everything is working great again. Thanks Google!

Rafe Safari

unread,
Sep 18, 2018, 10:45:10 AM9/18/18
to google-analytics-spreadsheet-add-on
I had the same. But figured out the root cause!!!!!
There are some good approaches in the other posts, but without knowing the root cause.
The root cause of mine was trying to copy a single cell... CAN YOU BELEIVE IT?

part of script was trying to clear a single row, and that damn cell was there.
i was trying to copy a single row and it suddenly crashes. restarted and continued copying cell by cell and figured out that an empty cell causes the crash. Deleted the column and all empty columns... then crossed through the heaven's gate! 

now, can copy entire row, also script works fine!!!!!

tai...@flexkeeping.com

unread,
Sep 19, 2018, 7:20:23 AM9/19/18
to google-analytics-spreadsheet-add-on
Sorry guys for offtopic, but nobody else replies - did anyone try the cohort analysis in the add-on? For me it doesn't work... Thanks in advance for your reply
Reply all
Reply to author
Forward
0 new messages