Why don't ads appear at all in the app?

35 views
Skip to first unread message

Arie Cahyadi

unread,
Apr 22, 2024, 5:23:23 AMApr 22
to Google Mobile Ads SDK Developers
Hello...
I want to ask, why can't my application display ads from my ad units. Even just to test the ad unit, it doesn't appear at all. I have tried various methods such as adding a test device ID to the source code but it failed, I have even tried adding a test device to the AdMob panel but it still fails.

If I use my ad units it will always show "ads failed to load: 3" and then if I try again it will show "ads failed to load: 1". I don't know what's wrong, but if I try to use the test ad unit from Google all the ads appear.

Even though my Admob account, my application, app-ads.txt have all been approved. I have even uploaded my application to Playstore. I have also submitted my tax information.

I hope you can help me solve this problem.
Thank You.

Mobile Ads SDK Forum Advisor

unread,
Apr 22, 2024, 9:43:21 AMApr 22
to arieca...@gmail.com, google-adm...@googlegroups.com
Hi,

Thank you for contacting Mobile ads SDK support team.

could you please confirm the following : 
  • Any "policy center" issue ? 
  • Does your account face any restriction.
  • Check that the eCPM floor settings not on high.
Kindly provide us the following details via Reply to author option if your issue hasn't got resolved after checking above information: 
  • app ID.
  • ad unit ID.
  • SDK version being used.
 

This message is in relation to case "ref:!00D1U01174p.!5004Q02tPGox:ref" (ADR-00232045)

Thanks,
 
Google Logo Mobile Ads SDK Team


Reply all
Reply to author
Forward
0 new messages