Getting SIGSEGV when running on Android 1.6 with Admob 4.0.4

300 views
Skip to first unread message

Taf

unread,
Apr 4, 2011, 6:50:25 PM4/4/11
to Google AdMob Ads Developers
Hi,

I'm getting a problem with the latest version of Admob 4.0.4 with
Android 1.6 on an ericsson xperia x10.

I'm seeing some errors in the log cat but I'm not sure if they are the
cause:


04-04 23:19:04.531: ERROR/EmojiFactory(20228):
EmojiFactory::GetAvailableImplementation() start
04-04 23:19:04.531: ERROR/EmojiFactory(20228):
EmojiFactory::GetAvailableImplementation() end failed!

But then after about the third Ad request I get an error and a
sigsegv. I've had the older version of admob running fine. Initially i
was running the new Admob version with Adwhirl so i thought it was an
Adwhirl fault. Also i've tried running with Admob and Adhwirl on a
Nexus S and everything works fine. Any help would be greatly
appreciated. The Error and the SISEGV from the Logcat is this:

04-04 23:19:04.671: ERROR/webcoreglue(20228): The real object has been
deleted
04-04 23:19:04.771: INFO/DEBUG(5729): *** *** *** *** *** *** *** ***
*** *** *** *** *** *** *** ***
04-04 23:19:04.771: INFO/DEBUG(5729): Build fingerprint: 'SEMC/
X10_1234-6152/SonyEricssonX10i/es209ra:1.6/R1DA007/1263868083:user/
test-keys'
04-04 23:19:04.771: INFO/DEBUG(5729): pid: 20228, tid: 20238 >>>
com.test.test<<<
04-04 23:19:04.771: INFO/DEBUG(5729): signal 11 (SIGSEGV), fault addr
00000000
04-04 23:19:04.771: INFO/DEBUG(5729): r0 00000007 r1 2c4a12f0 r2
2c4a12f0 r3 00000000
04-04 23:19:04.771: INFO/DEBUG(5729): r4 2c4a12f0 r5 001f4a28 r6
00000000 r7 313a5cac
04-04 23:19:04.771: INFO/DEBUG(5729): r8 313a5da0 r9 2c318e48 10
2c318e34 fp 00000001
04-04 23:19:04.771: INFO/DEBUG(5729): ip 6fbc30c8 sp 313a5c70 lr
6d044889 pc 6d03d806 cpsr 00000030
04-04 23:19:04.791: INFO/DEBUG(5729): #00 pc 0003d806 /
system/lib/libdvm.so
04-04 23:19:04.791: INFO/DEBUG(5729): #01 pc 001f336a /
system/lib/libwebcore.so
04-04 23:19:04.791: INFO/DEBUG(5729): #02 pc 0026029e /
system/lib/libwebcore.so
04-04 23:19:04.791: INFO/DEBUG(5729): #03 pc 000da460 /
system/lib/libwebcore.so
04-04 23:19:04.791: INFO/DEBUG(5729): #04 pc 000ec454 /
system/lib/libwebcore.so
04-04 23:19:04.791: INFO/DEBUG(5729): #05 pc 000df0ec /
system/lib/libwebcore.so
04-04 23:19:04.791: INFO/DEBUG(5729): #06 pc 00187d68 /
system/lib/libwebcore.so
04-04 23:19:04.801: INFO/DEBUG(5729): #07 pc 00187ee4 /
system/lib/libwebcore.so
04-04 23:19:04.801: INFO/DEBUG(5729): #08 pc 00187f10 /
system/lib/libwebcore.so
04-04 23:19:04.801: INFO/DEBUG(5729): #09 pc 0025816a /
system/lib/libwebcore.so
04-04 23:19:04.801: INFO/DEBUG(5729): #10 pc 0000e474 /
system/lib/libdvm.so
04-04 23:19:04.801: INFO/DEBUG(5729): #11 pc 0003e68e /
system/lib/libdvm.so

wes

unread,
Apr 4, 2011, 8:13:16 PM4/4/11
to google-adm...@googlegroups.com
If I remember correctly, this is most likely a representation of an early Android bug that was fixed in Froyo and higher.  I'm not sure if there's really much we can do; it stems from an occasional race condition deep down in the web view logic.

Cheers,
Wes

Taf

unread,
Apr 5, 2011, 4:16:39 AM4/5/11
to Google AdMob Ads Developers
Thanks for the reply.

I have had an older version of Admob working fine on this device,
haven't got the details of which version just now, but it was using
the old way of setup.

With this version of Admob my app is very unstable and crashes
frequently. Looking at the stats on Android market around 10% of my
users are using Android 1.6, which is tens of thousands of users.
So I'd really like a version of Admob that works with 1.6.

I'd be happy to try older versions and see if they are more stable.
I've had a look around on the web but can only find the latest version
for download.

Could someone point me in the direction to were I could download the
different versions of Admob so that I can try them out?

Thanks.

Taf

unread,
Apr 6, 2011, 4:29:38 AM4/6/11
to Google AdMob Ads Developers
Another developer who is also seeing this problem pointed me towards a
possible way of alleviating this problem:

http://stackoverflow.com/questions/4973310/signal-11-sigsegv-crash-android-solved

Is it possible that someone at Admob could take a look?

Thanks.

samiConnect

unread,
Apr 11, 2011, 6:35:04 PM4/11/11
to Google AdMob Ads Developers
I have the same problem , an it seems that the last admob sdk doesn't
support android 1.6 !! any solution ?

On 5 avr, 02:13, wes <wesgood...@google.com> wrote:
> If I remember correctly, this is most likely a representation of an early
> Android bug that was fixed in Froyo and higher.  I'm not sure if there's
> really much we can do; it stems from an occasional race condition deep down
> in the web view logic.
>
> Cheers,

ko5tik

unread,
Apr 12, 2011, 4:08:30 AM4/12/11
to Google AdMob Ads Developers


On Apr 12, 12:35 am, samiConnect <samiconn...@gmail.com> wrote:
> I have the same problem , an it seems that the last admob sdk doesn't
> support android 1.6 !! any solution ?

Downgrade to older SDK version. I still stay with latest AdMob-
Branded version and it works

sami Boussacsou

unread,
Apr 12, 2011, 7:10:02 AM4/12/11
to google-adm...@googlegroups.com
Please can you send me your version because i can't find it in the official google site.

2011/4/12 ko5tik <konstanti...@googlemail.com>

Sheado

unread,
Apr 12, 2011, 6:43:40 PM4/12/11
to Google AdMob Ads Developers
Hello,

I'm having the same issue here - even with older AdMob sdk (from
12/2010). I can reproduce it every time on a G1 running 1.6. We've
never noticed this problem before.
Our 1.6 users are going crazy - is there really no solution to this?
Should we shut off ads on 1.6 devices?

thanks.

On Apr 12, 4:10 am, sami Boussacsou <samiconn...@gmail.com> wrote:
> Please can you send me your version because i can't find it in the official
> google site.
>
> 2011/4/12 ko5tik <konstantin.pribl...@googlemail.com>

Michael Diener

unread,
Apr 21, 2011, 9:08:31 AM4/21/11
to Google AdMob Ads Developers
I had the same problem for Google AdMob 4.0.4 and AdWhirl 3.0.0. I
have fixed it by subclassing AdWhirlLayout the following way:

@Override
public void pushSubView(ViewGroup subView) {
RelativeLayout superView = superViewReference.get();
WebView wv = null;
if (superView != null && API_LEVEL <= 4)
wv = getAdViewWebView(superView);

super.pushSubView(subView);

if (wv != null)
wv.destroy();
}

private static WebView getAdViewWebView(ViewGroup v) {
WebView z = null;
for (int i=0; i<v.getChildCount() && z == null; i++) {
View child = v.getChildAt(i);
if (child instanceof WebView) {
if (v instanceof AdView)
z = (WebView)child;;
} else if (child instanceof ViewGroup)
z = getAdViewWebView((ViewGroup)child);
}
return z;
}

private static final int API_LEVEL = getApiLevel();
private static int getApiLevel() {
int sdk = 3;
try {
Field f = Build.VERSION.class.getField("SDK_INT");
sdk = f.getInt(null);
} catch (Throwable t) {
}
return sdk;
}


Hope this helps.

/Michael


On Apr 5, 12:50 am, Taf <neild...@gmail.com> wrote:
> Hi,
>
> I'm getting a problem with the latest version of Admob 4.0.4 with
> Android 1.6 on an ericsson xperia x10.
>
> I'm seeing some errors in the log cat but I'm not sure if they are the
> cause:
>
> 04-04 23:19:04.531: ERROR/EmojiFactory(20228):
> EmojiFactory::GetAvailableImplementation() start
> 04-04 23:19:04.531: ERROR/EmojiFactory(20228):
> EmojiFactory::GetAvailableImplementation() end failed!
>
> But then after about the third Ad request I get an error and asigsegv. I've had the older version of admob running fine. Initially i

grndvl1

unread,
May 4, 2011, 12:31:41 AM5/4/11
to Google AdMob Ads Developers
Same problem here on my G1 and the 1.6 emulator.

grndvl1

unread,
May 4, 2011, 12:32:45 AM5/4/11
to Google AdMob Ads Developers
What version of AdMob SDK works with 1.6 and where can I download it?

Tim

unread,
May 4, 2011, 1:36:39 AM5/4/11
to Google AdMob Ads Developers
This is a bug in Android's WebView in 1.6. We are working on a
workaround that should be available in the next release.

Thanks,
-Tim

William Ferguson

unread,
May 4, 2011, 6:37:20 AM5/4/11
to Google AdMob Ads Developers
Bonus points if its a solution that doesn't use WebView. It has too
many flaws to be usable in all but the most extreme scenarios (IMHO).

ubikdroid

unread,
May 15, 2011, 4:43:19 AM5/15/11
to Google AdMob Ads Developers
I am still having this issue using the GoogleAdMobAdsSdk-4.1.0.jar. I
am trying to migrate from using Google Adsense for Mobile apps before
the 30th June deadline. Please fix this so I can update my apps before
then.
Thanks

William Ferguson

unread,
May 16, 2011, 7:57:22 AM5/16/11
to Google AdMob Ads Developers
Tim, any update on this?

Is there any way we can switch off receiving those Ads that cause the
error?

Or should we just stop attempting to deliver Ads for 1.6?

William


On May 4, 3:36 pm, Tim <timzwie...@google.com> wrote:

Tim

unread,
May 16, 2011, 3:39:01 PM5/16/11
to Google AdMob Ads Developers
Please try calling AdView.destroy() in your onDestroy() method of your
Activity. This calls WebView.destroy(), which seems to prevent the
segmentation faults. Please keep in mind that this is a bug in Android
1.6 somewhere deep down in the WebView native code, so there's not a
whole lot that we can do. We're doing our best to provide workarounds
to these bugs in early versions of Android.

Thanks,
-Tim



On May 16, 4:57 am, William Ferguson <william.ferguson...@gmail.com>
wrote:

William Ferguson

unread,
May 17, 2011, 2:33:27 AM5/17/11
to Google AdMob Ads Developers
OK, thanks Tim, after adding AdView#destroy() I have hammered this for
the last 30 mins and haven't seen a SIGSEV.
NB AdView#destroy only exists in 4.1.0

Apc

unread,
Jun 19, 2011, 4:06:30 PM6/19/11
to Google AdMob Ads Developers
The fact is that Admob/Adesnse SDKs prior to 4.x do not show such
issues. At the same time we are forced to update to the new Adsense/
Admob version before June 30. Is there any chance to prolong this
term? Also, we have to workaround 1.5 incompatibilities too... No
doubt, previous versions were much more stable and flawless. They are
slower, but they are reliable. So now, after update to 4.1.0 we have
to code our own workarounds for 1.5 and 1.6 devices (more than 10-15%
of our users).

We are really wish to update to the new version ASAP, but I'm afraid
that some of our users will be unsatisfied. Not by ads, sdk, or
something else, but by our products at all :(
Reply all
Reply to author
Forward
0 new messages