API on pipeline instance returns 404

9 views
Skip to first unread message

David DOS SANTOS

unread,
Feb 12, 2024, 7:46:31 AMFeb 12
to go-cd
Hello,

I'm running an old version of GoCd Server (19.1.0), which I cannot upgrade for the moment.
For the first time in years, I need to get specific info from pipelines, so I'm playing with GoCD API, and i really appreciate the documentation on this.

So far, I tried with success the "pipeline history" endpoint :
GET /go/api/pipelines/:pipeline_name/history 

But when I need to get info on a specific instance :
GET /go/api/pipelines/:pipeline_name/:pipeline_counter

 I have the following error message:
{
    "message": "The resource you requested was not found!"
}

I tried various indexes/counters numbers, which I know are correct, but I always get the same message.
I also tried to suffix whith the stagename and stage_counter, but the error remains.

I checked on web, but ressources are really low on this great DevOps tool.

Thanks for you help.



Chad Wilson

unread,
Feb 12, 2024, 7:51:14 AMFeb 12
to go...@googlegroups.com
You need GET /go/api/pipelines/:pipeline_name/instance/:pipeline_counter to get an instance of a pipeline run - that should work?

-Chad

--
You received this message because you are subscribed to the Google Groups "go-cd" group.
To unsubscribe from this group and stop receiving emails from it, send an email to go-cd+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/go-cd/07072bb1-208b-4d19-b154-fe1c262a524dn%40googlegroups.com.

David DOS SANTOS

unread,
Feb 12, 2024, 9:04:17 AMFeb 12
to go-cd
Thanks a lot !!!

I was looking at API last version doc pages, and I understood the syntax I used should work on my 19.1.0 version.
I undestand now it means that the functionnality is here since 15.1.0, but the endpoint was a little bit different.

Thanks again !

David
Reply all
Reply to author
Forward
0 new messages