GOCD Server 21.2.0 Java version and Agent version mismatch (RHEL 7.6)

22 views
Skip to first unread message

Prakash K

unread,
Jun 2, 2021, 12:42:18 AMJun 2
to go-cd
Hello All, 

Hope all is well. 

We are still in the upgrade process. We have successfully both the server and agent to the latest version 21.2.0 and they are working with the below-mentioned JDK.

Go Server JDK: 1.8.0_191
Go Agent JDK: JDK-13.0.2 (Oracle JAVA)

It all works with the above-mentioned JAVA versions. But we want to avoid using Oracle java and use open JDK.  So I have installed openjdk-11.0.11.09 and configured agent to use this version. But getting the below error with this version. Does this mean I need to use same openjdk 11.0.11.09 for the server as well, pls suggest. Thanks, 

Agentbootstrapper has been compiled by a more recent version of the java runtime (class file version 57), this version of the java runtime only recognizes class file version upto 55.0

Marques Lee

unread,
Jun 2, 2021, 12:56:43 AMJun 2
to go...@googlegroups.com
Hello Prakash, I would say you should absolutely upgrade your server JDK. The fact that it even starts up is pure luck. We are currently compiling to a JDK 11 target which will likely change to a higher minimum JDK by the next release as we officially support “latest minus 2,” with the latest version being 16 as of now.

In other words, if it is working on JDK8, that is by accident. Currently, I would at least upgrade to JDK 11, if not JDK 15, which is the most tested.

--
You received this message because you are subscribed to the Google Groups "go-cd" group.
To unsubscribe from this group and stop receiving emails from it, send an email to go-cd+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/go-cd/b61eebad-07fd-4f25-89e8-ce20eb242567n%40googlegroups.com.

Prakash K

unread,
Jun 2, 2021, 1:02:43 AMJun 2
to go...@googlegroups.com
Thanks Marques, let me try to upgrade server idk. Thanks. 

Prakash K

unread,
Jun 2, 2021, 1:27:12 AMJun 2
to go...@googlegroups.com
Hi Marques,

I have changed set.JAVA_HOME in wrapper-config/wrapper-properties.conf to use openjdk-11.0.5.10-0 and restarted the service. 

Agent is using jdk-11.0.11.0.9 and still facing the same previous error. Am I missing anything else?

Sriram Narayanan

unread,
Jun 2, 2021, 1:44:48 AMJun 2
to go...@googlegroups.com
On Wed, Jun 2, 2021 at 1:27 PM Prakash K <prak...@gmail.com> wrote:
Hi Marques,

I have changed set.JAVA_HOME in wrapper-config/wrapper-properties.conf to use openjdk-11.0.5.10-0 and restarted the service. 

Class version 57 requires JRE 13. See: https://en.wikipedia.org/wiki/Java_class_file

Please start the server and the agent with JRE/JDK 13. 

@Marques: 
The target version is set to 13. See: https://github.com/gocd/gocd/blob/master/build.gradle#L162

-- Ram



 

Marques Lee

unread,
Jun 2, 2021, 4:19:09 AMJun 2
to go...@googlegroups.com
Ah yes, it looks like the minimum version has already been updated as of git commit d72a92d53b1406fce1a0c96558b904493bf657ab. My knowledge was outdated:


You should use at least JDK 13 for both server and agent, but preferably JDK 15 if you are able to as that is the version we test the most (and dogfood).

-Marques

Marques Lee

unread,
Jun 2, 2021, 4:20:30 AMJun 2
to go...@googlegroups.com
I don't know why I'm quoting that line again when Sriram already did :). Too impulsive at the keyboard before reading the whole message, lol. ignore me.

Prakash K

unread,
Jun 2, 2021, 4:33:53 AMJun 2
to go...@googlegroups.com
Thank you, I will proceed with jdk 15 for both server and agent. 

Reply all
Reply to author
Forward
0 new messages