gnus reading emails from fetchmail/procmail spool file(s)

13 views
Skip to first unread message

Martin Steffen

unread,
Jul 17, 2020, 7:38:35 AM7/17/20
to
Hi,

I have a seemingly trivial question (and actually I use gnus for
different sources since some time and it worked fine, but recently I
ran into trouble).

The thing I want to do is


use gnus to read email, and the email is taken from
a spool-file served via fetchmail/procmail

Not only did that work for me before, I had used it sporadically since
ages, it's also described in the info documentation.


Since recently my main way of accessing emails via gnus/imap was nnimap,
but became unreliable for some reason, so I wanted to go back to the
good old way, flush the server to a local spool file and then read it
in. Currently, no fancy stuff (splitting emails via procmail and/or gnus
etc, that will come later because I fail already at the very basics.

As far as I understand, the following should do the (basic) trick. I
want the "nnfolder"-method at the following place

~/Mail/ directory where the files reside
~/Mail/spool/ directory where fetchmail/procmail drops the mails
when polling the server

As a matter of fact, the spool-directory is already populated

~/Mail/spool/inbox.spool


I.e., the fetchmail-operation seemed to have worked (and the file looks
like some unix-style mailfolder)

I made a very minimal setup (normally, the setup for gnus is quite more
complex with other feeds, but I want to avoid ``interferences''). As far
as I understand the documentation, the following should do what I want



;--------------------------------------------------------------------
(setq gnus-select-method '(nnfolder ""))
(setq mail-sources
'((directory :path "~/Mail/spool/"
:suffix ".spool"))) ;;

-----------------------------------------------------------------------

(that seems to be the version from gnus 5.8 on replacing older ways of
setting things up invovling (setq nnmail-use-procmail t) and similar). I
tried also "file" instead of "directory". My remarks apply to both
variants).


I know one can set more things up (and I played around with more knobs
to fiddle with), but to my understanding, the very minimal 2-line
snippet form above should be a minimal set-up. I would expect, that,
when invoking M-x gnus, gnus should slurp in the
~/Mail/spool/inbox.spool file, process it somehow, put it to a file

~/Mail/inbox


and show it as ``news group'' in the *Group* buffer. But nothing
happens. The spool file seems untouched (perhaps with the minimal
config, gnus does not delete the spool-file) but its content is also not
transferred to ~/Mail/inbox.

FYI: The *Server* after starting gnus looks like
--------------
{nnfolder:archive} (opened)
{nndraft:} (opened)
{nnfolder:} (opened)
--------------


So far the problem description, and I just wonder


Have I overlooked something?

I did not read all of the manual (I use to use gnus since many years),
only the parts concerned with "using gnus for mail" and there mainly the
part for "nnfolder" (and in combination with procmail). Maybe I
overlooked some very basic.

Or

Can it be that the spool-file is messed up?

I am asking because the reason why I (re-)activate that way of
mail-reading is because the imap-access I used before (via gnus)
underwent some changes that degraded the nnimap-method of accessing
mails to the point of unusability. The imap-server configuration is
beyond my control and as information I got was that ``imap is for
non-standard users ony and not prioritized, so now wonder that things
are not working well''. Since fetchmail in my case uses IMAP, I wonder
whether not just gnu's nnimap-method is messed up, but, when flushing
the email to a procmail-spool, the resulting spool-file is messed up as
well, and gnus don't touch it. There is no error message from gnus
indicating that, and also fetchmail/procmail do their thing without
complaint, so I would think that is not the problem and may be a long
shot (but I am desparate and grasping for straws ;-)....)

Thanks, Martin

PS


emacs-version "26.3"
gnus--verion "Gnus v5.13"










Reply all
Reply to author
Forward
0 new messages