Gmote server "waiting for connection"

31 views
Skip to first unread message

Charles Hellaby

unread,
Nov 10, 2017, 8:26:29 AM11/10/17
to gmote...@googlegroups.com
I have a Windows 8.1 laptop and Samsung J100 phone. Both laptop and
phone are connected to the wireless network at work. (I haven't tried
at home yet.)

Today I installed the Gmote server & client. I had to install 32-bit
Java, as Gmote didn't find my 64-bit Java 1.8.

I started the Gmote server and created a password. It appeared in the tray.

I started the client, but it is unable to find my server. I got the
laptop IP address using your Gmote facility, and typed it in manually,
but the client still couldn't find it. I turned off Windows firewall
both private and public networks, and restarted both server and client.
Still nothing. (Turned firewall back on.)

I ran runServerDebugMode.bat both with the firewall on and with it off.

It gets stuck at "Waiting for a connection on port: 8889"

Thanks for any help


Charles Hellaby

unread,
Nov 10, 2017, 8:27:16 AM11/10/17
to gmote...@googlegroups.com
GmoteDebugLog2.txt

David Bolton

unread,
Nov 11, 2017, 8:22:24 AM11/11/17
to gmote...@googlegroups.com
I'd try it at home first. Your work may have network security that prevents the connection. 

---
David Bolton

--
You received this message because you are subscribed to the Google Groups "gmote users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to gmote-users+unsubscribe@googlegroups.com.
To post to this group, send email to gmote...@googlegroups.com.
Visit this group at https://groups.google.com/group/gmote-users.
For more options, visit https://groups.google.com/d/optout.

cwh

unread,
Nov 12, 2017, 12:12:36 AM11/12/17
to gmote users
Thanks for replying David.  I tried it at home with the same result.  Both my devices connect to a wireless router.  See attached debug mode log.

cwh

unread,
Nov 12, 2017, 12:13:23 AM11/12/17
to gmote users

C:\Program Files (x86)\GmoteServer>java -classpath bin;lib\slf4j-api-1.5.3.jar;l
ib\jna.jar;lib\swing-worker-1.2.jar org.gmote.server.GmoteServerUiWindows loglev
el=ALL
Nov 12, 2017 7:07:23 AM org.gmote.server.GmoteServerUi sharedMain
WARNING: Gmote Version: 2.0.2
Nov 12, 2017 7:07:23 AM org.gmote.server.GmoteServerUi sharedMain
WARNING: OperatingSystem: Windows 8.1
Nov 12, 2017 7:07:24 AM org.gmote.server.MulticastServerThread run
INFO: Listening for udp packets on 9901
Nov 12, 2017 7:07:24 AM org.gmote.server.settings.SupportedFiletypeSettings <ini
t>
INFO: Initializing supported file types settings.
Nov 12, 2017 7:07:24 AM org.gmote.server.settings.SupportedFiletypeSettings <ini
t>
INFO: Done initializing supported file types settings.
Nov 12, 2017 7:07:24 AM org.gmote.server.media.MediaPlayerManager createNewMedia
PlayerInstance
INFO: Creating media player with name: org.gmote.server.media.vlc.VlcMediaPlayer

Nov 12, 2017 7:07:24 AM org.gmote.server.ServerUtil findInstallDirectory
WARNING: Current directory: C:\Program Files (x86)\GmoteServer
[00000001] main libvlc debug: VLC media player - version 0.9.6 Grishenko - (c) 1
996-2008 the VideoLAN team
[00000001] main libvlc debug: libvlc was configured with ./configure  '--host=i5
86-mingw32msvc' '--build=i386-linux' '--enable-mkv' '--enable-release' '--withou
t-contrib' '--enable-nls' '--enable-shared-libvlc' '--enable-update-check' '--en
able-lua' '--enable-faad' '--enable-flac' '--enable-theora' '--enable-twolame' '
--enable-quicktime' '--enable-real' '--enable-realrtsp' '--enable-ffmpeg' '--wit
h-ffmpeg-mp3lame' '--with-ffmpeg-faac' '--with-ffmpeg-config-path=/usr/win32/bin
' '--with-ffmpeg-zlib' '--enable-live555' '--with-live555-tree=/usr/win32/live.c
om' '--ena
[00000001] main libvlc debug: translation test: code is "C"
[00000001] main libvlc debug: opening config file (C:\Users\ratty\AppData\Roamin
g\vlc\vlcrc)
[00000001] main libvlc debug: checking builtin modules
[00000001] main libvlc debug: checking plugin modules
[00000001] main libvlc debug: recursively browsing `C:\ProgramData\Oracle\Java\j
avapath\modules'
[00000001] main libvlc debug: recursively browsing `C:\ProgramData\Oracle\Java\j
avapath\plugins'
[00000001] main libvlc debug: recursively browsing `C:\Program Files (x86)\Gmote
Server\bin\vlc\plugins'
[00000353] main module warning: cannot find symbol "vlc_entry__0_9_0m" in file `
C:\Program Files (x86)\GmoteServer\bin\vlc\plugins\libxml_plugin.dll' (The speci
fied procedure could not be found. (error 127))
[00000001] main libvlc debug: module bank initialized, found 260 modules
[00000001] main libvlc debug: opening config file (C:\Users\ratty\AppData\Roamin
g\vlc\vlcrc)
[00000001] main libvlc debug: CPU has capabilities 486 586 MMX MMXEXT SSE SSE2 F
PU
[00000001] main libvlc debug: looking for memcpy module: 3 candidates
[00000001] main libvlc debug: using memcpy module "memcpymmxext"
[00000357] main interaction debug: thread 5444 (Interaction control) created at
priority 0 (interface/interaction.c:382)
[00000357] main interaction debug: thread started
[00000359] main input debug: Creating an input for 'Media Library'
[00000359] main input debug: Input is a meta file: disabling unneeded options
[00000359] main input debug: `file/xspf-open://C:\Users\ratty\AppData\Roaming\vl
c\ml.xspf' gives access `file' demux `xspf-open' path `C:\Users\ratty\AppData\Ro
aming\vlc\ml.xspf'
[00000359] main input debug: creating access 'file' path='C:\Users\ratty\AppData
\Roaming\vlc\ml.xspf'
[00000360] main access debug: looking for access module: 2 candidates
[00000360] access_file access debug: opening file `C:\Users\ratty\AppData\Roamin
g\vlc\ml.xspf'
[00000360] main access debug: using access module "access_file"
[00000360] main access debug: TIMER module_Need() : 1.000 ms - Total 1.000 ms /
1 intvls (Avg 1.000 ms)
[00000361] main stream debug: Using AStream*Stream
[00000361] main stream debug: pre-buffering...
[00000361] main stream debug: received first data for our buffer
[00000359] main input debug: creating demux: access='file' demux='xspf-open' pat
h='C:\Users\ratty\AppData\Roaming\vlc\ml.xspf'
[00000362] main demux debug: looking for demux module: 1 candidate
[00000362] playlist demux debug: using XSPF playlist reader
[00000362] main demux debug: using demux module "playlist"
[00000362] main demux debug: TIMER module_Need() : 0.000 ms - Total 0.000 ms / 1
 intvls (Avg 0.000 ms)
[00000359] main input debug: `file/xspf-open://C:\Users\ratty\AppData\Roaming\vl
c\ml.xspf' successfully opened
[00000363] main xml debug: looking for xml module: 1 candidate
[00000363] main xml debug: using xml module "xtag"
[00000363] main xml debug: TIMER module_Need() : 0.000 ms - Total 0.000 ms / 1 i
ntvls (Avg 0.000 ms)
[00000362] playlist demux warning: invalid <playlist> attribute:"xmlns:vlc"
[00000362] playlist demux debug: parsed 0 tracks successfully
[00000363] main xml debug: removing module "xtag"
[00000359] main input debug: EOF reached
[00000359] main input debug: control type=1
[00000362] main demux debug: removing module "playlist"
[00000360] main access debug: removing module "access_file"
[00000359] main input debug: TIMER input launching for 'Media Library' : 7.000 m
s - Total 7.000 ms / 1 intvls (Avg 7.000 ms)
[00000364] main preparser debug: waiting for thread initialization
[00000364] main preparser debug: thread started
[00000364] main preparser debug: thread 5520 (preparser) created at priority 0 (
playlist/thread.c:79)
[00000365] main fetcher debug: waiting for thread initialization
[00000365] main fetcher debug: thread started
[00000365] main fetcher debug: thread 5592 (fetcher) created at priority 0 (play
list/thread.c:108)
[00000358] main playlist debug: waiting for thread initialization
[00000358] main playlist debug: thread started
[00000358] main playlist debug: rebuilding array of current - root Playlist
[00000358] main playlist debug: rebuild done - 0 items, index -1
[00000358] main playlist debug: thread 5540 (playlist) created at priority 0 (pl
aylist/thread.c:117)
[00000366] main interface debug: looking for interface module: 1 candidate
[00000366] main interface debug: using interface module "hotkeys"
[00000366] main interface debug: TIMER module_Need() : 0.000 ms - Total 0.000 ms
 / 1 intvls (Avg 0.000 ms)
[00000366] main interface debug: thread 5508 (interface) created at priority 0 (
interface/interface.c:168)
[00000366] main interface debug: thread started
Nov 12, 2017 7:07:24 AM org.gmote.server.GmoteServer startServer
INFO: Waiting for TCP connection on port: 8889
Reply all
Reply to author
Forward
0 new messages