Navboxes move to the default position after page refresh

9 views
Skip to first unread message

Anatol Pomozov

unread,
Feb 5, 2009, 4:50:55 PM2/5/09
to Navbar drag and drop
Some people reported about this issue so I decided to add a sticky
topic.

DragnDrop Lab works incorrectly with Offline - after you enable Gmail
offline navboxes jump to initial position after page reload.

It is a known bug of this Lab feature that works incorrectly with
Gmail offline. It happens because of race condition in receiving
settings data. Offline provides default data for navbar builder before
it receives data from server/storage.

Anyway this bug is fixed locally as of today (February 5) and it will
be available in production until the end of the February. Let me know
if you would have this problem after this period of time.

wowtim

unread,
Feb 19, 2009, 12:15:36 AM2/19/09
to Navbar drag and drop
This is not fixed for me. Like several other users, it does not
remember the location of my Calendar bar. It remembers when I change
the location of everything else, though.

Joana Souza

unread,
Feb 19, 2009, 1:58:26 PM2/19/09
to Navbar drag and drop
I can't move them back! I moved de labels box to the right, and now it
won´t go back to the left, neither the other boxes move to anywhere!

Gordon

unread,
Feb 21, 2009, 1:44:04 PM2/21/09
to Navbar drag and drop
Still not working for me yet on 21 February - keep having to move
navboxes around every time Gmail is reloaded.

Hope fix comes soon - this is an excellent feature! :)

Gordon

unread,
Feb 21, 2009, 1:44:23 PM2/21/09
to Navbar drag and drop
Still not working for me yet on 21 February - keep having to move
navboxes around every time Gmail is reloaded.

Hope fix comes soon - this is an excellent feature! :)

On Feb 5, 9:50 pm, Anatol Pomozov wrote:

mfaber3

unread,
Feb 21, 2009, 5:49:09 PM2/21/09
to Navbar drag and drop
As of Feb. 21, I still have the problem of navboxes jumping back to
original position. I'm also running RTM gadget.

Thanks,
Monica

thar

unread,
Feb 26, 2009, 4:53:24 PM2/26/09
to Navbar drag and drop
same here, still coming back to the default postion

Kristof Gilleman

unread,
Feb 27, 2009, 3:31:48 AM2/27/09
to Navbar drag and drop
indeed on 27/02/2009 I still have the issue that chat always comes on
top after a reload, while I put it downwards just before.
seems that the order is still not preserved when using the offline
feature

JulieJayne

unread,
Mar 1, 2009, 4:20:36 PM3/1/09
to Navbar drag and drop
01/03/09 After reload, Chat still comes up to the top.

But strangely enough if I open a second instance of Gmail, the
Calender is on top as I wanted it to be and reloading this instance of
Gmail it stays as it should.

Can anyone explain that.
Or can anyone else reproduce this effect?

skymoo

unread,
Mar 2, 2009, 9:20:02 PM3/2/09
to Navbar drag and drop


On Feb 5, 3:50 pm, Anatol Pomozov wrote:

> Anyway this bug is fixed locally as of today (February 5) and it will
> be available in production until the end of the February. Let me know
> if you would have this problem after this period of time.

Still seeing this problem, in fact its got a little weirder. I just
renabled Drag and Drop, waited for Gmail to restart (as I use offline)
and then tried to move things around. Nothing would move, I would get
the dotted lines showing where I could move the items to but nothing
would actually move.

JulieJayne

unread,
Mar 4, 2009, 2:45:58 AM3/4/09
to Navbar drag and drop
Try again now, there have been some updates, and for me Drag and drop
is now working correctly

denipak

unread,
Mar 4, 2009, 8:59:20 PM3/4/09
to Navbar drag and drop
ditto here.
it used to work fine, but now (probably also since switching the gmail
offline feature on) it seems to reorder itself at will and i cant move
anything anywhere right now!!

Arbil

unread,
Mar 4, 2009, 8:59:22 PM3/4/09
to Navbar drag and drop
Even after making OFFLINE inactive, Drag & Drop is still not working -
I cannot move anything anywhere - like skymoo says, it looks like it
is moving, but as soon as you let go of the mouse, nothing happens
> > would actually move.- Hide quoted text -
>
> - Show quoted text -

Rodrigo Queiroz

unread,
Mar 5, 2009, 6:28:57 AM3/5/09
to Navbar drag and drop
Same here. I'm not using the Offline feature, and everything moves to
their default positions after refresh. Besides, it's really hard to
dragn'n drop anything on screen. I'm using FF 3.0.6

On 19 fev, 02:15, wowtim wrote:

anato...@google.com

unread,
Mar 5, 2009, 8:38:02 PM3/5/09
to Navbar drag and drop
Ok, we've find another edge case bug with Offline. It's a pity that I
find them too late when they are released into production. So fix is
submitted and I hope that it will be available to you early next week
(Mar 9-11).

Mikest

unread,
Mar 5, 2009, 11:31:38 PM3/5/09
to Navbar drag and drop
If you click on the labs icon, it snaps everything to where you had
them. Oddly enough, I didn't have the problem at all last month (and
Offline was turned on) it just started yesterday for me.

Anatol Pomozov

unread,
Mar 6, 2009, 1:05:22 AM3/6/09
to Navbar drag and drop
Hi
A correction: the fix will be available somewhere around Mar-20

starla5501

unread,
Mar 30, 2009, 10:31:34 PM3/30/09
to Navbar drag and drop
I have Offline and used Navbar. Every time I open Gmail, my chat is
below my labels. I use Navbar to move it back,and low and behold, the
next time I use Gmail it is in the wrong place again. What gives?

starla5501

unread,
Mar 30, 2009, 10:31:42 PM3/30/09
to Navbar drag and drop
I have Offline and used Navbar. Every time I open Gmail, my chat is
below my labels. I use Navbar to move it back,and low and behold, the
next time I use Gmail it is in the wrong place again. What gives?

On Mar 6, 1:05 am, Anatol Pomozov wrote:

skymoo

unread,
Mar 31, 2009, 12:36:55 AM3/31/09
to Navbar drag and drop


On Mar 6, 1:05 am, Anatol Pomozov wrote:

> A correction: the fix will be available somewhere around Mar-20

Looks like a new version of Gmail has been rolled out (10624497) and
this problem is back. The position I had things is forgotten on
subsequent sessions.

roody102

unread,
Apr 3, 2009, 8:53:41 AM4/3/09
to Navbar drag and drop
I've tried to reorganize my sidebar after Multiple Inboxes were fixed
and it does not work right now.
roody102

roody102

unread,
Apr 3, 2009, 9:05:13 AM4/3/09
to Navbar drag and drop
It's even more annoying - after turning it off Quick Links are on the
top. It's even worse for me, than I had before trying it :(
r.

Donadio

unread,
Apr 6, 2009, 4:13:17 PM4/6/09
to Navbar drag and drop
I am also having this problem. Everything moves back to their default
positions regardless of offline activation. Thank you for any updates

J-DAWG

unread,
Apr 14, 2009, 1:00:05 PM4/14/09
to Navbar drag and drop
It still goes back to default positions every time I reload or log
back in as well. Luckily, I don't have too many items on the sidebar
to move back :)

laxer

unread,
Apr 21, 2009, 9:56:17 PM4/21/09
to Navbar drag and drop
It seems that each time I sign in it changes, but it seems to have
changed to a different order each time (I have the labels, chat, and
calender navboxes active) although I haven't been keeping track of
what they reorganize to so I may be mistaken to say its a different
order each time

LeM

unread,
May 2, 2009, 4:51:57 PM5/2/09
to Navbar drag and drop
doesn't work for me as well, and I don't have offline enabled.

LeM

unread,
May 2, 2009, 4:53:57 PM5/2/09
to Navbar drag and drop
now that I try it, the order changes every time i refresh it. It
doesn't go to 'default' always.

no name

unread,
May 5, 2009, 5:56:51 PM5/5/09
to Navbar drag and drop
i have offline enabled (in google chrome) and when i refresh the page
this same thing happens. i hope this gets fixed!

4Jonah

unread,
May 9, 2009, 10:28:10 PM5/9/09
to Navbar drag and drop
im having the same problem. glad im not alone

4Jonah

unread,
May 9, 2009, 10:29:25 PM5/9/09
to Navbar drag and drop
UPDATE: i had NavBar enabled for some time w/o the issue (using
Offline), but once I added Google Search, thats whenthe problem began
for me!)

christian

unread,
May 12, 2009, 6:43:30 AM5/12/09
to Navbar drag and drop
Hi, I don't use offline mode and my navbar doesn't save the position
when refresh.

Juan Pedro

unread,
May 17, 2009, 10:00:24 PM5/17/09
to Navbar drag and drop
I've just disabled the Offline... and the problem still happens.
Any ideas how to solve it?

Thanks!!

micche

unread,
May 27, 2009, 2:01:27 PM5/27/09
to Navbar drag and drop
I've the same problem, the boxes order change any time I start a new
session :(

kmich

unread,
Jun 5, 2009, 9:34:01 AM6/5/09
to Navbar drag and drop
This problem still/again seems to be present. I am using XP/Chrome. I
have not yet been able to consistently repeat it, but it does occur
frequently. I'm sure it is tied to varying states Offline chooses to
take when I try to open Gmail. I often wonder if Offline Labs is worth
the roadbumps...

kmich

unread,
Jun 5, 2009, 11:55:31 AM6/5/09
to Navbar drag and drop
I 'Disable Offline Gmail for this computer' and have again experienced
my Navboxes resorting themselves. I will try to Disable the Offline
Labs feature completely. Is it possible there may be a conflict with
the 'Add any gadget by URL' feature?

kmich

unread,
Jun 5, 2009, 5:37:58 PM6/5/09
to Navbar drag and drop
Completely disabling Offline did not fix the problem. This appears to
be unrelated to Offline.

SMY

unread,
Jun 16, 2009, 9:03:28 AM6/16/09
to Navbar drag and drop
I've never used Offline, and I'm still having this problem. I like my
boxes to be top to bottom: Calendar, Chat, Labels. But it always
reverts to Labels, Chat, Calendar upon refresh. I have to move
everything back. Under the regular settings, I set it as ": Show the
chat box ABOVE the Labels box," and yet they move around everytime.

Thanks!

Juan Pedro

unread,
Jun 17, 2009, 12:00:03 PM6/17/09
to Navbar drag and drop
Ok, here is my solution to make it remember again the positions.

1. Disable "Tasks", "Google Calendar gadget" and "Navbar drag and
drop"

2. Enable "Tasks", "Google Calendar gadget" and "Navbar drag and drop"

3. Move the "Calendar gadget" over the "Task" link

4. Press "Ctrl+F5"

5. Place the "Calendar gadget" where you want

6. Solved... or at least for me.

Hope this helps.
Reply all
Reply to author
Forward
0 new messages