Rendering issues with Adreno GPU

Skip to first unread message

Jun 20, 2016, 6:30:24 AM6/20/16
to GLyphy


I have managed to adapt glyphy to compile using ndk-build tool for Android platform and using cmake on Linux gcc environment.
It compiles and runs fine and I tested it on nVidia and intel integrated GPUs on Linux, but on Android I have problem running on some devices powered by
Adreno GPU - LG G3, Galaxy S4 and and Asus Nexus 7 2013. You can see the look of the text rendered on the following images:

Everything is rendered fine on Genymotion virtual machine and on the Galaxy S6 wih Mali T760 GPU.

I don't have any other devices to invesitage further, but I suspect that this has to be related wit the shader compiler for the specified GPU.
Is there anything I could to to avoid the problem?


Bernard Čupić
Auto Generated Inline Image 1
Auto Generated Inline Image 2
Auto Generated Inline Image 3
Auto Generated Inline Image 4
Auto Generated Inline Image 5

Behdad Esfahbod

Jul 23, 2016, 1:44:09 AM7/23/16
Hi Bernard,

Excuse me for the late response.

Unfortunately I had to deal with similar issues with any driver I tried GLyphy with.  Typically these result from substandard or just different implementations of float and int precision in shaders.  There is no easy way to fix them; they need debugging and coming up with guesses as to what the problem is, and working around them :(.

Did you have any further luck?


You received this message because you are subscribed to the Google Groups "GLyphy" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
For more options, visit


Sep 1, 2016, 5:40:30 AM9/1/16
to GLyphy

No, I have been busy with some other stuff. I have postponed it for later investigation. I haven't idea where to start with this, is it a driver problem or what?


Mar 5, 2019, 12:19:20 PM3/5/19
to GLyphy

I had the same problem on the Windows platform rendering enscripten compiled code. These issues are evident regardles of the graphic card. I managed to trace down the problem to the glyphy_sdf function.
It seems that windows drivers doesn't like to copy glyphy_arc_endpoint_t (prev_endpoint = endpoint) so instead I opted to copy only vec2 point (since it is the enough), but it has to be done at the end of the loop.
I will create the pull request with this fix. Now it works as expected.

Reply all
Reply to author
0 new messages