GlasqsFish 4.0.1 Build 4でビルドが失敗する不具合について

46 views
Skip to first unread message

Kenji HASUNUMA

unread,
Feb 13, 2014, 9:02:55 PM2/13/14
to glas...@googlegroups.com
先日公開されたばかりのGlassFish 4.0.1 Build 4ですが、ソースコードをチェックアウトしてビルドを試みると必ず失敗する不具合を発見しました。

この不具合は、appserver/pom.xmlの依存関係記述で、JAX-WS実装であるwebservicesとjaxbのバージョンが、Maven Central Repositoryに存在しなかったことによるものです(現在、GlassFishの依存モジュールはすべてMaven Centralに登録されていることになっています)。

この不具合は早急に修正される、とのことです。

本件は下記Issueで登録されています。
https://java.net/jira/browse/GLASSFISH-20981

Kenji HASUNUMA

unread,
Feb 21, 2014, 11:57:49 AM2/21/14
to glas...@googlegroups.com
GLASSFISH-20981はクローズしました。併せて注意事項があります。

結局のところ、GlassFish 4.0.1 Promoted Build をソースコードからビルドする場合、開発用の Maven リポジトリも指定しないとダメです、ということです。GLASSFISH-20981 で問題となった Metro と JAXB RI の最新版も、開発用のリポジトリを参照することで依存関係を解決することができます。

詳細な手順は下記ハスヌマのブログ記事を参照願います。

2014年2月14日金曜日 11時02分55秒 UTC+9 Kenji HASUNUMA:
Reply all
Reply to author
Forward
0 new messages