2.0 error message

33 views
Skip to first unread message

Mary Mangan

unread,
Sep 30, 2013, 12:45:07 PM9/30/13
to gitool...@googlegroups.com
Hi folks--

I was kicking the tires on the 2.0 version just to see what it was like. I was going to start by replicating the steps of the existing tutorials to see what the differences were. But right away I ran into an issue.

It may be a known issue, but I thought I'd let you see what transpired. I'm on a PC with Win7 if it matters.

http://screencast.com/t/1qO8Y6rFA This is a short screencast of what I saw after I launched from this page: http://www.gitools.org/download

First I noticed that I couldn't select a radio button like the previous version. But I clicked "next" anyway in case it was different, but then I get the little error dialog window.

Let me know if this was some kind of pilot error on my part, or if there's something I need to install, or if you want me to try something else.

Thanks.

Mary


Michael P Schroeder

unread,
Oct 1, 2013, 5:45:39 AM10/1/13
to gitool...@googlegroups.com
Hi Mary

Thank you very much for this detailed descriptions. You have discovered 2 bugs at once, here the explanation:

1. With the release of IntOGen Mutations, the URL for IntOGen has changed and thus the error message when you try to import data from IntOGen arrays (the old version).
2. We have already discovered that the Java upate 25 of Java 7 is letting components of Dialogs disappear (see https://github.com/gitools/gitools/issues/104) and we think you may have the same problem. Could you please confirm on which Java version Gitools is running? We have prepared a webstart for Gitools that will thell you the exact version. Please follow the instructions below:


- Run Gitools via this webstart link which will directly open a heatmap with IntOGen Mutations data available through Gitools datasets. The link is: http://webstart.gitools.org/2.0.0-SNAPSHOT/gitools.jnlp?load=http://bg.upf.edu/gitools-tcga/data/intogen/intogen-genes-by-project.heatmap.zip
- Select the menu "Help -> About Gitools" and please report the version you will find in the pop-up window.

If you have Java 7u25, there are two existing solutions:
    - If you like, you could try if the problem is solved with Java 7u40.
    - There is also a simple workaround; you have to enable the java console. Follow these steps: http://www.java.com/en/download/help/javaconsole.xml

Some remarks about IntOGen data. The tutorial you were following would import data from the submodule of IntOGen which now is called IntOGen arrays. If you would like to browse mutation data or other cancer genomics data from TCGA and TCGA Pancancer I'd propose that you go to www.gitools.org/datasets, they are best fit to show the new capabilities that Gitools 2.0.0 will have. 

Thanks for your time,
Michael

Mary Mangan

unread,
Oct 1, 2013, 11:54:49 AM10/1/13
to gitool...@googlegroups.com
Yes, that's definitely the version I've got: http://screencast.com/t/1fOQBYz7W

Just wanted to report that right away so you'll know. And I'll try the other options later when I have a chance. I'll try the workaround first, and the upgrade to 40 later if it doesn't.

And thanks for the tips on the data. I was just looking to compare the differences at this point and get to know the tools, so I wasn't wedded to the IntOGen strategy that was part of the tutorial. I'll try going deeper later.

Thanks for the response.

Mary


--
You received this message because you are subscribed to a topic in the Google Groups "Gitools users" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/gitools-users/7LyvbpFAEDE/unsubscribe.
To unsubscribe from this group and all its topics, send an email to gitools-user...@googlegroups.com.
Visit this group at http://groups.google.com/group/gitools-users.

Reply all
Reply to author
Forward
0 new messages