Website Issues

6 views
Skip to first unread message

Paul Merrell

unread,
Jun 2, 2017, 4:06:53 PM6/2/17
to ghil...@googlegroups.com
I haven't looked at the website in a while, but I've noticed several things that were working before are now broken. The most obvious is that on the tutorial pages I created only the first mathematical formula is typeset. The remaining formula are not typeset and their links are missing. For example,


Did something change recently?

Paul

Raph Levien

unread,
Jun 3, 2017, 4:35:47 PM6/3/17
to ghil...@googlegroups.com
Yes, I'm seeing the same thing. I haven't dug into why. I haven't changed anything regarding the appengine instance in a while; it must be some changes in some of our dependencies. I did play around with the site a few weeks ago and it seemed to be working then.

I'm not very focused on maintaining the existing website because I'm planning on rewriting most of it. That said, I'd happily take fixes.

Raph


--
You received this message because you are subscribed to the Google Groups "Ghilbert" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ghilbert+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Adam Bliss

unread,
Jun 4, 2017, 4:21:38 PM6/4/17
to ghil...@googlegroups.com
The javascript console says:
cdn.mathjax.org has been retired. Check https://www.mathjax.org/cdn-shutting-down/ for migration
Uncaught ReferenceError: MathJax is not defined
    at Function.GH.typeset.formatWiki (typeset.js:495)
    at sampler:85

Adam Bliss

unread,
Jun 4, 2017, 4:39:10 PM6/4/17
to ghil...@googlegroups.com
I sent a pull request on github, but I don't seem to be allowed to update the ghilbert-app instance. 

Raph Levien

unread,
Jun 4, 2017, 4:41:40 PM6/4/17
to ghil...@googlegroups.com
I don't remember the auth state of the ghilbert-app instance, but it's probably easiest for me to update that myself. I'll have to re-install the tools...

In any case, thanks for fixing the CDN issue!

Raph

Raph Levien

unread,
Jun 5, 2017, 12:40:34 AM6/5/17
to ghil...@googlegroups.com
This should be fixed. Thanks to both of you for noticing and fixing.

I also updated the github repo with the (small) config change needed, which should be useful if anyone wants to experiment with their own app engine instance.

Raph
Reply all
Reply to author
Forward
0 new messages