64-bit installers

697 views
Skip to first unread message

Ian

unread,
Sep 29, 2010, 9:19:24 PM9/29/10
to GGobi users
Hi all,

I have a feature request if it is not too much trouble. On my Mac, I
can install and run ggobi, and rggobi works just fine with 32-bit R,
but I get errors with 64-bit R (see below). I assume that this is due
to a mis-match of bityness, and might possibly be solved by building
ggobi in 64 bits. I could not immediately figure out how to do this.

Would it be possible to provide 64-bit installers for mac/windows?


Cheers,
Ian














> library(rggobi)
Error in dyn.load(file, DLLpath = DLLpath, ...) :
unable to load shared library '/Library/Frameworks/R.framework/
Resources/library/rggobi/libs/x86_64/rggobi.so':
dlopen(/Library/Frameworks/R.framework/Resources/library/rggobi/libs/
x86_64/rggobi.so, 6): Library not loaded: /usr/local/ggobi/lib/
libggobi.0.dylib
Referenced from: /Library/Frameworks/R.framework/Resources/library/
rggobi/libs/x86_64/rggobi.so
Reason: no suitable image found. Did find:
/usr/local/ggobi/lib/libggobi.0.dylib: no matching architecture in
universal wrapper
Error : .onLoad failed in loadNamespace() for 'rggobi', details:
call: fun(...)
error: Could not load the rggobi library - please ensure GGobi is on
the library path
Error: package/namespace load failed for 'rggobi'
> sessionInfo()
R version 2.11.1 (2010-05-31)
x86_64-apple-darwin9.8.0

locale:
[1] en_US.UTF-8/en_US.UTF-8/C/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] stats graphics grDevices utils datasets methods
base

loaded via a namespace (and not attached):
[1] RGtk2_2.12.18

Lars

unread,
Sep 30, 2010, 2:25:06 AM9/30/10
to GGobi users
Hi,
I have the same request. I have published an R-package on the cran
repository which depends on rggobi and hence GGobi (http://cran.r-
project.org/web/packages/beadarrayMSV/index.html). As long as a 64-bit
windows binary installer for GGobi is not available, we will not be
able to create a 64-bit windows version of my package either. I'm
afraid this may seriously limit the potential number of users of this
package.

A 64-bit binary for windows is thus greatly anticipated!
Thanks,
Lars

Hadley Wickham

unread,
Oct 4, 2010, 4:10:39 PM10/4/10
to Ian, GGobi users
Hi Ian,

64-bit works on the mac (see below for instruction). 64-bit windows
may be a little longer.

Regards,

Hadley

# Install gtk
curl -O http://r.research.att.com/libs/GTK_2.18.5-X11.pkg
open GTK_2.18.5-X11.pkg

# Install ggobi
curl -O http://r.research.att.com/libs/ggobi-2.1.8-darwin9-bin3.tar.gz
sudo tar fvxz ggobi-2.1.8-darwin9-bin3.tar.gz -C /

# Install rggobi
export PATH=/usr/local/ggobi/bin:/Library/Frameworks/GTK+.framework/Resources/bin:$PATH
export PKG_CONFIG_PATH=/usr/local/ggobi/lib/pkgconfig:/Library/Frameworks/GTK+.framework/Resources/lib/pkgconfig

R
install.packages("rggobi", type = "source")

> --
> You received this message because you are subscribed to the Google Groups "GGobi users" group.
> To post to this group, send email to gg...@googlegroups.com.
> To unsubscribe from this group, send email to ggobi+un...@googlegroups.com.
> For more options, visit this group at http://groups.google.com/group/ggobi?hl=en.
>
>

--
Assistant Professor / Dobelman Family Junior Chair
Department of Statistics / Rice University
http://had.co.nz/

Reply all
Reply to author
Forward
0 new messages