Printer 2.68 firmware not working: heat settings might be the issue.

28 views
Skip to first unread message

Giulio Ammendola

unread,
Feb 5, 2017, 4:19:08 AM2/5/17
to Printer
HI there, 

I have got mi circuit setup with an arduino, ethernet shield and a thermal printer from adafruit. 
Unfortunately I can't get it to print much.

- Test page: it tries to print it but only have of "Your printer" header actually comes out. Nothing else is on the page.

- Direct message using the mail app provided: Nothing comes out at all. The server side works, the leds do their job, but once I press the button the printer tries to do something and ejects some white paper. 


I have tried running the example adafruit sketch and the printer works perfectly. I have also tried the printer demo mode (pressing the printer button while powering it) and the demo page comes out perfectly.

The firmare version indicated in the demo page is 2.68 (which is not listed in the github page FAQ), heat dot=80. I thought the problem might be something to do with the darkness settings so I have tried changing that but no significant difference was made. 

Has everyone managed to get a 2.68 firmware printer working? Do you have any suggestion? It's such a shame, because I know the printer works with adafruit example sketch, but not with the exciting stuff!!



Let me know
Many thanks

Best, Giulio 

Giulio

unread,
Feb 5, 2017, 4:22:33 AM2/5/17
to Printer
IMG_3342.JPG
IMG_3343.JPG
IMG_3344.JPG
Reply all
Reply to author
Forward
0 new messages