Thanks Omat,
>>> "TypeError: Result of expression 'this.popup' [undefined] is not an
>>> object."
I fixed a bug in the popup handling that was causing this error message
you saw. Pull the latest from
http://github.com/yourcelf/olwidget and
it ought to work now.
> Btw, is it possible to disable the popup for the initial layer? Or at
> least change its name, so that it won't popup as 'data'? The 'name'
> attribute given during map initialization does not seem to have an
> effect.
You can remove the default vector layer after creating the map:
map = olwidget.InfoMap(....);
map.removeLayer(map.vectorLayer);
You can change the name of the default vector layer by passing a 'name'
parameter either in the django or javascript map constructors. In my
testing, this works as it should. If it's not working for you, please
file an issue on github with a failing example and I'll look into it.
cheers,
Charlie
p.s. Omat, it may be appropriate to leave issues with olwidget to other
channels, such as the github issues list, rather than the geodjango
mailing list. I am working on
http://code.djangoproject.com/ticket/5472
to incorporate olwidget into Django trunk, but until that happens, it's
probably best to keep olwidget discussions here topical to that ticket.
If folks disagree please correct me.