Can´t put SpagoBI to run using my own data

410 views
Skip to first unread message

Eduardo Kanegae

unread,
May 24, 2010, 9:29:47 AM5/24/10
to ge...@googlegroups.com
Hi all, I´m a system administrator, not a java player, have some PHP
production open source packs running and we´re currently trying to run
SpagoBI with our own dataset.

== What we already did:
- download and run
Demo-SpagoBI-2.5.0-apache-tomcat-6.0.18-04092010.zip : this was fine.
We could access and run reports, dashboards, maps, etc from this
demo-set
- 2nd step: follow HowToUseSpagoBIInstaller-1.9.3-07252007.pdf
instructions. This was also fine, and Spago works using demo data from
this pack

== What we tried and can´t do:
- we follow steps from SpagoBI_How_To-v1.7.pdf including '4.1 How to
add a new datawarehouse connection?', 4.1.4 (connection for Spago
Core), 4.1.5 (connection for Spago Engines), '4.2How to change SpagoBI
metadata database ?' (and also run db scripts to create metadata
schemas )

But now, what is the next step? I can still login using biadmin but
when login using 'staff_gen' I got 7 error boards showing "No
templates are available for the document ".
Or in some menu commands like QbE I got "Generic Error "

Is there any dummy tutorial? We are studying SpagoBI because the need
of mixing reports, charts, maps, dashboards over consolidated dataset
but It´s not clear for if I MUST or not to be a Java programmer to
achieve some results with SpagoBI.

thanks in advance for any help.
-
Eduardo Kanegae

--
Hai ricevuto questo messaggio perché sei iscritto al gruppo "geobi" di Google Gruppi.
Per postare messaggi in questo gruppo, invia un'email a ge...@googlegroups.com.
Per annullare l'iscrizione a questo gruppo, invia un'email a geobi+un...@googlegroups.com.
Per ulteriori opzioni, visita il gruppo all'indirizzo http://groups.google.com/group/geobi?hl=it.

Fabio D'Ovidio

unread,
May 24, 2010, 9:52:13 AM5/24/10
to ge...@googlegroups.com
Hello Eduardo,
first of all thank you for using GeoReport with SpagoBI.

I'll try to answer you as following but remeber this is not the official
Mailing List of SpagoBI but that one for GeoReport.

Eduardo Kanegae ha scritto:
> == What we tried and can´t do:
> - we follow steps from SpagoBI_How_To-v1.7.pdf including '4.1 How to
> add a new datawarehouse connection?', 4.1.4 (connection for Spago
> Core), 4.1.5 (connection for Spago Engines), '4.2How to change SpagoBI
> metadata database ?' (and also run db scripts to create metadata
> schemas )
>
> But now, what is the next step? I can still login using biadmin but
> when login using 'staff_gen' I got 7 error boards showing "No
> templates are available for the document ".
> Or in some menu commands like QbE I got "Generic Error "
>
> Is there any dummy tutorial?
you must write to SpagoBI ML or Forum here:

* http://forge.ow2.org/mail/?group_id=204
* http://forge.ow2.org/forum/?group_id=204


> We are studying SpagoBI because the need
> of mixing reports, charts, maps, dashboards over consolidated dataset
> but It´s not clear for if I MUST or not to be a Java programmer to
> achieve some results with SpagoBI.
>
In order to use SpagoBI with an OGC compliant WebGIS client like
GeoReport (and so not with a SVG file as Spagobi already does), you must
follow here:

* http://wiki.spagobi.org/xwiki/bin/view/spagobi_server/GeoReport

So you must not be a JAVA programmer but you must edit and configure
some files and templates as described above.

Let us know!

Thank you again.

Fabio D'Ovidio
Reply all
Reply to author
Forward
0 new messages