Vector Tiles light basemap: wrong style URL

18 views
Skip to first unread message

Daniel Ursprung

unread,
Mar 28, 2022, 6:33:31 AMMar 28
to GeoAdminCh API
I have problems loading light Basemap using Vector Tiles Service. A few months ago, I successfully created a new Vector Tile Connection in QGIS with the following information:

URL (to load tiles):  
https://vectortiles14.geo.admin.ch/mbtiles/ch.swisstopo.leichte-basiskarte.vt/v006/{z}/{x}/{y}.pbf  
 
Style-URL (to load style):  
http://vectortiles.geo.admin.ch/gl-styles/ch.swisstopo.leichte-basiskarte.vt/v006/style.json

This does not work any more. I checked the Swisstopo Website, but was not able to find a working URL:
https://www.geo.admin.ch/de/geo-dienstleistungen/geodienste/darstellungsdienste-webmapping-webgis-anwendungen/vector_tiles_service.html#verf%C3%BCgbar

The URL for the vector tiles seems to be correct: I am able to load the tiles with an alternative syle URL:
https://vectortiles.geo.admin.ch/tiles/ch.swisstopo.leichte-basiskarte.vt/v1.0.0/tiles.json

But the style is not correct, see screenshot here:
https://www.daniel-ursprung.ch/vectortiles.png

Can anyone help getting the URL for a/the correct style ?

David...@swisstopo.ch

unread,
Mar 28, 2022, 7:14:53 AMMar 28
to geoadm...@googlegroups.com

You are using an outdated old Version: Version 1.0.0  as shown in https://api3.geo.admin.ch/services/sdiservices.html#id45 is up to date

An how to for QGIS:

https://github.com/cividi/geohackmin/discussions/48

--
You received this message because you are subscribed to the Google Groups "GeoAdminCh API" group.
To unsubscribe from this group and stop receiving emails from it, send an email to geoadmin-api...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/geoadmin-api/bc27f7b5-97b3-4f14-af2c-7196a9b97f01n%40googlegroups.com.

Daniel Ursprung

unread,
Mar 28, 2022, 4:29:52 PMMar 28
to GeoAdminCh API
OK, great, that works, thanks a lot. However, the first site you linked to does not mention the correct tiles URL: https://vectortiles10.geo.admin.ch/.... , it has https://vectortiles.geo.admin.ch/... So do I miss something or does the correct link lack on the Swisstopo Website?

David...@swisstopo.ch

unread,
Mar 29, 2022, 1:30:04 AMMar 29
to geoadm...@googlegroups.com
vectortiles.geo.admin.ch Is correct
The other URLs are aliases - and are used in http acceleration context…

________________________________

Von: Daniel Ursprung <da...@access.uzh.ch>
Datum: 28. März 2022 um 22:30:01 MESZ
An: GeoAdminCh API <geoadm...@googlegroups.com>
Betreff: Re: Vector Tiles light basemap: wrong style URL

OK, great, that works, thanks a lot. However, the first site you linked to does not mention the correct tiles URL: https://vectortiles10.geo.admin.ch/.... , it has https://vectortiles.geo.admin.ch/... So do I miss something or does the correct link lack on the Swisstopo Website?

David...@swisstopo.ch schrieb am Montag, 28. März 2022 um 13:14:53 UTC+2:
You are using an outdated old Version: Version 1.0.0 as shown in https://api3.geo.admin.ch/services/sdiservices.html#id45 is up to date
An how to for QGIS:
https://github.com/cividi/geohackmin/discussions/48


Von: geoadm...@googlegroups.com <geoadm...@googlegroups.com> Im Auftrag von Daniel Ursprung
Gesendet: Montag, 28. März 2022 12:34
An: GeoAdminCh API <geoadm...@googlegroups.com>
Betreff: Vector Tiles light basemap: wrong style URL

I have problems loading light Basemap using Vector Tiles Service. A few months ago, I successfully created a new Vector Tile Connection in QGIS with the following information:

URL (to load tiles):
https://vectortiles14.geo.admin.ch/mbtiles/ch.swisstopo.leichte-basiskarte.vt/v006/{z}/{x}/{y}.pbf<https://vectortiles14.geo.admin.ch/mbtiles/ch.swisstopo.leichte-basiskarte.vt/v006/%7bz%7d/%7bx%7d/%7by%7d.pbf>

Style-URL (to load style):
http://vectortiles.geo.admin.ch/gl-styles/ch.swisstopo.leichte-basiskarte.vt/v006/style.json

This does not work any more. I checked the Swisstopo Website, but was not able to find a working URL:
https://www.geo.admin.ch/de/geo-dienstleistungen/geodienste/darstellungsdienste-webmapping-webgis-anwendungen/vector_tiles_service.html#verf%C3%BCgbar

The URL for the vector tiles seems to be correct: I am able to load the tiles with an alternative syle URL:
https://vectortiles.geo.admin.ch/tiles/ch.swisstopo.leichte-basiskarte.vt/v1.0.0/tiles.json

But the style is not correct, see screenshot here:
https://www.daniel-ursprung.ch/vectortiles.png

Can anyone help getting the URL for a/the correct style ?
--
You received this message because you are subscribed to the Google Groups "GeoAdminCh API" group.
To unsubscribe from this group and stop receiving emails from it, send an email to geoadmin-api...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/geoadmin-api/bc27f7b5-97b3-4f14-af2c-7196a9b97f01n%40googlegroups.com<https://groups.google.com/d/msgid/geoadmin-api/bc27f7b5-97b3-4f14-af2c-7196a9b97f01n%40googlegroups.com?utm_medium=email&utm_source=footer>.

--
You received this message because you are subscribed to the Google Groups "GeoAdminCh API" group.
To unsubscribe from this group and stop receiving emails from it, send an email to geoadmin-api...@googlegroups.com<mailto:geoadmin-api...@googlegroups.com>.
To view this discussion on the web visit https://groups.google.com/d/msgid/geoadmin-api/6358e6a5-fe7a-45ee-8a26-7e430119a497n%40googlegroups.com<https://groups.google.com/d/msgid/geoadmin-api/6358e6a5-fe7a-45ee-8a26-7e430119a497n%40googlegroups.com?utm_medium=email&utm_source=footer>.

Daniel Ursprung

unread,
5:14 PM (2 hours ago) 5:14 PM
to GeoAdminCh API

Sorry, I again have the same problem. I can't load Leichte Basiskarte in QGIS 3.26. I can't find the correct URL for pbf and style, I always get an error message. In the links to the Swisstopo Website, there are a lot of URL's, however I'm not sure which one to use and why this URL seems to change so often.
Reply all
Reply to author
Forward
0 new messages