Gears for Safari beta

171 views
Skip to first unread message

Jeremy Moskovich

unread,
Aug 25, 2008, 12:46:00 PM8/25/08
to gear...@googlegroups.com, gears...@googlegroups.com
Hi,

We are excited to share a beta version of Gears for Safari with you!!  We would love for you to install it and test it and file bug reports so we can polish it and find all the corner cases.

Please note a few important points before you download:

1. This is BETA, it is not an official release, it might break your browser. Chances are it will break your browser. Please proceed with caution.

2. Please do not forward the download, since it's still in beta, we would like to make sure we patch up any issues before we officially release it.

3. Minimum system requirements: Safari 3.1.1 on Tiger 10.4.11 or Leopard 10.5.3.

4. Make sure you have Gears 0.4.16.0 before you file bugs. You can check your version on http://gears.google.com.

5. You can see a list of known bugs at: http://code.google.com/p/gears/issues/list?can=2&q=Safari
                         New bugs can be filed on our public tracker at: http://code.google.com/p/gears/issues/list

6. This version will autoupdate, so once you have it installed you'll automagically get new versions as we release them.

I want to reiterate that you are likely to have bugs and/or instability so please be aware of this before you install.

You can download here: http://dl.google.com/gears/current/gears-osx-opt.dmg


Thank you and we look forward to your feedback!!

Ben Lisbakken

unread,
Aug 25, 2008, 1:20:52 PM8/25/08
to gear...@googlegroups.com, gears...@googlegroups.com
Congrats Jeremy on this release!  I'm sure many Apple users will be very happy.

Talleyrand

unread,
Aug 26, 2008, 10:22:29 AM8/26/08
to Gears Users
Hi Jeremy,

Seems that you were talking about Firefox for MacOSX instead of
Safari. I get a "Your browser is not currently supported.
Please check the list of supported browsers below." under Safari.
System requirements

* Windows XP/Vista
* Firefox 1.5+ and Internet Explorer 6.0+

* Linux (details)
* Firefox 1.5+
* 32-bit OS (64-bit not supported)

* Mac OS X 10.4+
* Firefox 1.5+

Regards,

Luc

ceebee

unread,
Aug 26, 2008, 11:02:24 AM8/26/08
to Gears Users
Excellent news - off to break Safari now :)

One related question - are there any plans for a centralized list of
sites/applications that utilize Gears?

Chris

Jeremy Moskovich

unread,
Aug 26, 2008, 12:29:15 PM8/26/08
to gears...@googlegroups.com
Hi,

Our official download page and documentation don't yet list Safari as a supported platform, but we'll fix that once we've done an official release (see: http://code.google.com/p/gears/issues/detail?id=695).

In the meantime, you can download the Safari version via the link in the original message.

Thanks and best regards,
Jeremy

Ben Lisbakken

unread,
Aug 26, 2008, 12:42:09 PM8/26/08
to gears...@googlegroups.com
Ceebee --

We have a list of projects on the "featured section" on our homepage, but it's gotten pretty stale as we haven't been actively adding to it.  Over the next few weeks I will start gathering projects to put up there.

-Ben

ceebee

unread,
Aug 26, 2008, 2:48:56 PM8/26/08
to Gears Users
Thanks for that Ben, will keep an eye on that page.

- Chris

Blake Burris

unread,
Aug 26, 2008, 5:48:47 PM8/26/08
to Gears Users
wOOt! Just a week after a Twittered about the eternal wait for Gears
on Safari. Thanks Jeremy and team!

On Aug 25, 11:46 am, Jeremy Moskovich <playmo...@google.com> wrote:
> Hi,
>
> We are excited to share a beta version of Gears for Safari with you!!  We
> would love for you to install it and test it and file bug reports so we can
> polish it and find all the corner cases.
>
> Please note a few important points before you download:
>
> 1. This is BETA, it is not an official release, it might break your browser.
> Chances are it will break your browser. Please proceed with caution.
>
> 2. Please do not forward the download, since it's still in beta, we would
> like to make sure we patch up any issues before we officially release it.
>
> 3. Minimum system requirements: Safari 3.1.1 on Tiger 10.4.11 or Leopard
> 10.5.3.
>
> 4. Make sure you have Gears 0.4.16.0 before you file bugs. You can check
> your version onhttp://gears.google.com.
>
> 5. You can see a list of known bugs at:http://code.google.com/p/gears/issues/list?can=2&q=Safari
> <http://code.google.com/p/gears/issues/list?can=2&q=Safari%20>

Mr. Wizard

unread,
Aug 26, 2008, 11:28:59 PM8/26/08
to Gears Users
How's it go for Webkit?

Aaron Boodman

unread,
Aug 27, 2008, 12:48:08 PM8/27/08
to gears...@googlegroups.com
Mr Wizard,

I'm lost. Can you explain your question a little more?

- a

Jason Essington

unread,
Aug 27, 2008, 12:54:44 PM8/27/08
to gears...@googlegroups.com
If you are talking about webkit nightly builds on OS X, then sure, it
appears to work fine.

just install the package and restart webkit, and you are good to go.

-jason

Jeremy Moskovich

unread,
Aug 27, 2008, 3:30:18 PM8/27/08
to gears...@googlegroups.com, gear...@googlegroups.com
Just wanted to make sure that everyone is aware that the version posted sends crash reports back to Google.
This is important for us, since one of the major goals of this release is to gauge stability.

Paul B. Adams

unread,
Aug 28, 2008, 5:46:58 AM8/28/08
to Gears Users
I've installed the beta but when I go to Google Reader or Google Docs,
I don't get an option to work offline (works fine under Firefox 3)

The plugin and input manager both seem to be in the right folders of /
Library.

I had Safari 4.0 Beta previously installed, but removed it and tried
re-installing Gears - still nothing.

Am I missing something obvious?

I've raised this as an issue (number 701)

Regards,
Paul Adams.

Jeremy Moskovich

unread,
Aug 28, 2008, 10:07:49 AM8/28/08
to gears...@googlegroups.com
Hi Paul,

Do you see a "Google Gears Settings..." menu item in the Safari application menu?  If so, that means Gears is installed correctly.

Best regards,
Jeremy

trevor

unread,
Aug 27, 2008, 9:58:47 PM8/27/08
to Gears Users
Jeremy, you should update your release notification to include the
MAXIMUM system requirements:

On Aug 25, 9:46 am, Jeremy Moskovich <playmo...@google.com> wrote:
> 3. Minimum system requirements: Safari 3.1.1 on Tiger 10.4.11 or Leopard
> 10.5.3.


I have Safari Version 4 Developer Preview (5526.11.2) installed and
gears for safari beta refuses to install, insisting that it requires
v3.1.1 "or later" (which is obviously not accurate since v4 is clearly
"later" than v3.1.1...).

Better than updating the min sys req notice though would be to update
the installer so that it can actually figure out that 4 > 3.1.1. :-)

-Trevor

Paul B. Adams

unread,
Aug 28, 2008, 12:16:09 PM8/28/08
to Gears Users
No, not a sign of anything on any menu nor in the Safari Preferences.

Any ideas?

On Aug 28, 3:07 pm, Jeremy Moskovich <playmo...@google.com> wrote:
> Hi Paul,
>
> Do you see a "Google Gears Settings..." menu item in the Safari application
> menu?  If so, that means Gears is installed correctly.
>
> Best regards,
> Jeremy
>

Jeremy Moskovich

unread,
Aug 28, 2008, 12:25:16 PM8/28/08
to gears...@googlegroups.com
Hi Trevor,

This sounds like a bug in the Installer version detection logic, Gears should work fine with the new v4 betas but the installer apparently isn't detecting them correctly.

I've opened http://code.google.com/p/gears/issues/detail?id=703 to track this.  I'll post updates there when I have more information.

Thanks for the report!,
Jeremy

Eduard Grebe

unread,
Aug 28, 2008, 9:24:26 PM8/28/08
to Gears Users
Gears will not install on my machine (OSX 10.5.4 and Safari 3.1.2 on
Macbook Pro), giving the following rather mystifying error message:

"Google Gears cannot be installed on this computer.
Could not find specified message for index 31."

Any ideas about this?

Orion Richardson

unread,
Aug 28, 2008, 5:38:40 PM8/28/08
to Gears Users
That's great, Jeremy! Congrats.

We just tried this with our new offline application for Zhura.com
(still to be released) and it worked incredibly well except for one
issue:

When trying to create a desktop shortcut, JavaScript returned an error
and the page reloaded (probably because we were inside a form and it
submitted). I don't have an error code for you yet (will try to get
one), but we didn't see any link created on the desktop... This was
with Safari 3.1.2 on Mac OS X 10.4.11. Maybe you can reproduce.

Thanks and keep up the great work.

Orion

On Aug 25, 12:46 pm, Jeremy Moskovich <playmo...@google.com> wrote:
> Hi,
>
> We are excited to share a beta version of Gears for Safari with you!!  We
> would love for you to install it and test it and file bug reports so we can
> polish it and find all the corner cases.
>
> Please note a few important points before you download:
>
> 1. This is BETA, it is not an official release, it might break your browser.
> Chances are it will break your browser. Please proceed with caution.
>
> 2. Please do not forward the download, since it's still in beta, we would
> like to make sure we patch up any issues before we officially release it.
>
> 3. Minimum system requirements: Safari 3.1.1 on Tiger 10.4.11 or Leopard
> 10.5.3.
>
> 4. Make sure you have Gears 0.4.16.0 before you file bugs. You can check
> your version onhttp://gears.google.com.
>
> 5. You can see a list of known bugs at:http://code.google.com/p/gears/issues/list?can=2&q=Safari
> <http://code.google.com/p/gears/issues/list?can=2&q=Safari%20>

Jeremy Moskovich

unread,
Aug 29, 2008, 7:37:42 PM8/29/08
to gears...@googlegroups.com, gear...@googlegroups.com
I've mailed Eduard privately, but in case anyone else is having trouble with the installer, could you please run the attached script by unzipping it and double clicking it in the Finder and then send me the output.

This will allow us to diagnose the problem.

Best regards,
Jeremy
gears_install_check.zip

trevor

unread,
Aug 30, 2008, 12:27:42 AM8/30/08
to Gears Users
Without emailing you the full results, I'll wager this is the problem
here:

Caught exception: [Errno 2] No such file or directory: '/Applications/
Safari.app/Contents/Info.plist'

I have Safari living in a folder called /Applications/Web Browsers
with my other web browsers. Once upon a time, Safari updates got
tricked by this but eventually they changed their logic (don't recall
when) because updates have auto detected where it is for quite some
time. So I forgot about that until after I first posted. Later I
wondered if that was the problem but it seemed too obvious.

On Aug 29, 4:37 pm, Jeremy Moskovich <playmo...@google.com> wrote:
> I've mailed Eduard privately, but in case anyone else is having trouble with
> the installer, could you please run the attached script by unzipping it and
> double clicking it in the Finder and then send me the output.
>
> This will allow us to diagnose the problem.
>
> Best regards,
> Jeremy
>
> On Thu, Aug 28, 2008 at 6:24 PM, Eduard Grebe <eduardgr...@gmail.com> wrote:
>
> > Gears will not install on my machine (OSX 10.5.4 and Safari 3.1.2 on
> > Macbook Pro), giving the following rather mystifying error message:
>
> > "Google Gears cannot be installed on this computer.
> > Could not find specified message for index 31."
>
> > Any ideas about this?
>
>
>
>  gears_install_check.zip
> 2KViewDownload

Pyro3d

unread,
Aug 29, 2008, 10:36:08 PM8/29/08
to Gears Users
I've experienced the same problem that Paul has, and when loading
Safari 4(DP2), my console.log reports this:

2008-08-29 19:14:10.798 Safari[17294] *** -[NSBundle load]: Error
loading code /Library/InputManagers/GearsEnabler/GearsEnabler.bundle/
Contents/MacOS/GearsEnabler for bundle /Library/InputManagers/
GearsEnabler/GearsEnabler.bundle, error code 2 (link edit error code
0, error number 0 ())

Hope this helps.
-Pyro

Jeremy Moskovich

unread,
Aug 30, 2008, 5:38:04 PM8/30/08
to gears...@googlegroups.com
Do you have a G3 mac?

Pyro3d

unread,
Aug 31, 2008, 2:37:23 AM8/31/08
to Gears Users
Yeah, I do. Is this one of those G3 specific issues?

Jeremy Moskovich

unread,
Aug 31, 2008, 9:49:13 AM8/31/08
to gears...@googlegroups.com
Yes, we currently don't support G3 macs.

This is an issue we just became aware of, so we didn't mention it in the original mail (http://code.google.com/p/gears/issues/detail?id=708).

I'm sorry you're affected by this.

Best regards,
Jeremy

Narfmaster

unread,
Sep 1, 2008, 7:12:04 PM9/1/08
to Gears Users
Path=[['/Users/Alex/Downloads', '/System/Library/Frameworks/
Python.framework/Versions/2.5/lib/python25.zip', '/System/Library/
Frameworks/Python.framework/Versions/2.5/lib/python2.5', '/System/
Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/plat-
darwin', '/System/Library/Frameworks/Python.framework/Versions/2.5/lib/
python2.5/plat-mac', '/System/Library/Frameworks/Python.framework/
Versions/2.5/lib/python2.5/plat-mac/lib-scriptpackages', '/System/
Library/Frameworks/Python.framework/Versions/2.5/Extras/lib/python', '/
System/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/
lib-tk', '/System/Library/Frameworks/Python.framework/Versions/2.5/lib/
python2.5/lib-dynload', '/Library/Python/2.5/site-packages', '/System/
Library/Frameworks/Python.framework/Versions/2.5/Extras/lib/python/
PyObjC']]

Caught exception: [Errno 2] No such file or directory: '/Applications/
Safari.app/Contents/Info.plist'
logout

Is mine, and doesn't like the install. Says the usual "Needs 3.1.1 or
later" when attempting, running 3.1.2 at the moment.

On Aug 30, 12:37 am, Jeremy Moskovich <playmo...@google.com> wrote:
> I've mailed Eduard privately, but in case anyone else is having trouble with
> the installer, could you please run the attached script by unzipping it and
> double clicking it in the Finder and then send me the output.
>
> This will allow us to diagnose the problem.
>
> Best regards,
> Jeremy
>
> On Thu, Aug 28, 2008 at 6:24 PM, Eduard Grebe <eduardgr...@gmail.com> wrote:
>
> > Gears will not install on my machine (OSX 10.5.4 and Safari 3.1.2 on
> > Macbook Pro), giving the following rather mystifying error message:
>
> > "Google Gears cannot be installed on this computer.
> > Could not find specified message for index 31."
>
> > Any ideas about this?
>
>
>
>  gears_install_check.zip
> 2KViewDownload

Jeremy Moskovich

unread,
Sep 2, 2008, 1:02:12 PM9/2/08
to gears...@googlegroups.com
Thanks,

Short version: There's a bug in the beta installer where it reports an error if Safari.app isn't located in /Applications .

To get the installer working, move Safari.app back into /Applications, run installer, once the installer has run you're free to move Safari wherever you like.

See http://code.google.com/p/gears/issues/detail?id=709

Best regards,
Jeremy

tumpak

unread,
Sep 9, 2008, 3:03:30 AM9/9/08
to Gears Users
I downloaded the beta installer yesterday.

I have safari 3.1.2 but the installer refuses to install saying "it
needs safari 3.1.1 and higher"

some one else has this bug , saw it in one of the threads. any luck ?

I am using Ibook G4. and have OS 10.4.11 installed.

am really excited to try this out and hoping for gears for google apps
(gmail/calendar) soon !

thanks a lot for making the world easier place to live :)

tumpak from nepal



On Sep 2, 10:02 pm, Jeremy Moskovich <playmo...@google.com> wrote:
> Thanks,
>
> Short version: There's a bug in the beta installer where it reports an error
> if Safari.app isn't located in /Applications .
>
> To get the installer working, move Safari.app back into /Applications, run
> installer, once the installer has run you're free to move Safari wherever
> you like.
>
> Seehttp://code.google.com/p/gears/issues/detail?id=709
>
> Best regards,
> Jeremy

tumpak

unread,
Sep 9, 2008, 9:46:43 AM9/9/08
to Gears Users
I have safari 3.1.2 but the installer for gears says " I need Safari
3..1.1 or more" repeatedly. Must be a bug that doesn't recognize
3.1.2. Any one else have similar problems. Seems a few might actually
have them.

Also i am using mac os 10.4.11 on a ibook G4.

thanks for the wonderful app and look forward to gmail with gears.

tumpak
> > > Gears will not install on my machine (OSX 10.5.4 andSafari3.1.2 on
Reply all
Reply to author
Forward
0 new messages