iperf3 not working despite allowing port in firewall

20 views
Skip to first unread message

King De Leon

unread,
Jun 9, 2021, 8:17:45 AMJun 9
to gce-discussion
  Hi,
I want to test the network speed from my home network because it's taking 16 seconds to download a 1MB file:


I tried running iperf3 -s -p 5201 in the VM and allowed ingress on the same port in the Firewall Google Cloud page. I also allowed the port in Linux UFW.

However, when running iperf3 -c <ip> on my PC, it doesn't connect. I tried to do iperf to another network from my PC and it worked.

Are there other settings I need to adjust in GC?

Digil (Google Cloud Platform Support)

unread,
Sep 2, 2021, 4:19:34 PMSep 2
to gce-discussion

There could be many reasons for the failure of running the iperf3 tool. As commented in the stackoverflow.com thread, you should be considering various parameters checklists while using the iperf3.

As explained in Google Cloud's community tutorial, if you would like to allow the server and client communication through the Google Cloud firewall, you only need to create a firewall rule to the iPerf3 server to allow ingress TCP on the selected port. It seems like no other configuration requirements are in need for the Google Cloud Platform's firewall rules. 

If the iPerf3 tool is not assisting you very well in your situation, you may need to advance your testing with the help of other well-documented tools such as Netperf or  Perfkit Benchmarker as an alternative.  

Reply all
Reply to author
Forward
0 new messages