Getting Error "Kernel panic - not syncing: VFS: Unable to mount root fs

26 views
Skip to first unread message

Arunesh Dutta

unread,
Nov 24, 2021, 8:02:38 AM11/24/21
to gce-discussion
Hello all

I am running Ubutnu in one of instance in Google Cloud, while performing upgrades it had frozen for long time and then later when I tried to connect as usual using SSH the connection couldn't be established and in the serial console also I am getting an error "Kernel panic - not syncing: VFS: Unable to mount root fs ", kindly guide what steps should I follow to rescue the instance running in Google Cloud and make it running fine again, have the storage drive earlier used with instance also intact and comfortably attached to instance

Here is the attached image of error


Untitled.png

Derek Murphy

unread,
Nov 28, 2021, 10:33:24 AM11/28/21
to gce-discussion

Hello,

Here is a possible solution to your problem, let me know if it works for you.

  1. Mount the disk to another instance, see link [1]

  2. Update grub.cfg to use the previous kernel version. 

Note : make sure you are changing the correct grub.cfg file. If there are linuxefi and/or initrdefi entries in the grub.cfg file, then it most probably uses the /etc/grub2-efi.cfg file that points to /boot/efi/EFI/redhat/grub.cfg, instead of /etc/grub2.cfg that points to /boot/grub2/grub.cfg.

  1. Attach the disk to the faulty instance, see link[1]

  2. The instance is able to boot

  3. Reinstall the kernel

  4. Reboot the instance

I'm curious to see if this worked in your case, have a nice day.

from : Derek

[1] Detaching and reattaching boot disks :

https://cloud.google.com/compute/docs/disks/detach-reattach-boot-disk

Reply all
Reply to author
Forward
0 new messages