Report generation fails with ArrayIndexOutOfBoundsException

138 views
Skip to first unread message

m...@miracle.dk

unread,
Feb 20, 2017, 5:00:56 AM2/20/17
to Gatling User Group
Hi,

I have run a simulation which runs for 45 minutes on 12 nodes. When I download the logs and try to generate a report (using -ro) I get the error below:

Parsing log file(s)...

Exception in thread "main" java.lang.ArrayIndexOutOfBoundsException: -543557658

at io.gatling.charts.stats.buffers.CountsBuffer.update(CountBuffer.scala:35)

at io.gatling.charts.stats.buffers.ResponsesPerSecBuffers$class.updateResponsesPerSecBuffers(ResponsesPerSecBuffers.scala:32)

at io.gatling.charts.stats.ResultsHolder.updateResponsesPerSecBuffers(ResultsHolder.scala:21)

at io.gatling.charts.stats.ResultsHolder.addRequestRecord(ResultsHolder.scala:48)

at io.gatling.charts.stats.LogFileReader.io$gatling$charts$stats$LogFileReader$$$anonfun$9(LogFileReader.scala:150)

at io.gatling.charts.stats.LogFileReader.io$gatling$charts$stats$LogFileReader$$$anonfun$9$adapted(LogFileReader.scala:145)

at scala.collection.Iterator$class.foreach(Iterator.scala:893)

at scala.collection.Iterator$ConcatIterator.foreach(Iterator.scala:168)

at io.gatling.charts.stats.LogFileReader.secondPass(LogFileReader.scala:145)

at io.gatling.charts.stats.LogFileReader.io$gatling$charts$stats$LogFileReader$$$anonfun$10(LogFileReader.scala:165)

at io.gatling.charts.stats.LogFileReader.parseInputFiles(LogFileReader.scala:63)

at io.gatling.charts.stats.LogFileReader.<init>(LogFileReader.scala:165)

at io.gatling.app.RunResultProcessor.initLogFileReader(RunResultProcessor.scala:67)

at io.gatling.app.RunResultProcessor.processRunResult(RunResultProcessor.scala:49)

at io.gatling.app.Gatling$.start(Gatling.scala:61)

at io.gatling.app.Gatling$.fromArgs(Gatling.scala:41)

at io.gatling.app.Gatling$.main(Gatling.scala:33)

at io.gatling.app.Gatling.main(Gatling.scala)


All machines are running Gatling 2.2.3.

The problem looks like #3084 whis is marked as fixed in 2.2.3 (https://github.com/gatling/gatling/issues/3084).

Any idea what could be causing this and how to fix it?

Martin

Paul Lanzerstorfer

unread,
Mar 20, 2017, 5:38:09 AM3/20/17
to Gatling User Group
I also faced the same problem when Gatling tried to generate the report after a run.

This seems to happen for other users as well: https://groups.google.com/d/msg/gatling/rck59PJyihA/Ki3fp65fAgAJ

Paul Lanzerstorfer

unread,
Mar 20, 2017, 10:58:06 AM3/20/17
to Gatling User Group
I should probably add that my problems seem to coincide with my change to make use of "{" and "}" in the http calls, without these everything seems to work fine again.

However, I suppose that this is most likely not the real, underlying issue.


Am Montag, 20. Februar 2017 11:00:56 UTC+1 schrieb m...@miracle.dk:
Reply all
Reply to author
Forward
0 new messages