ArrayIndexOutOfBoundsException when attempting to construct report

119 views
Skip to first unread message

Clint McGill

unread,
Sep 30, 2016, 3:06:29 PM9/30/16
to Gatling User Group
Hi,
Trying to generate a report from a concurrent run on several remote servers. Have already done so several times.  Now, suddenly, I'm getting this:

GATLING_HOME is set to /home/ubuntu/gatling
Parsing log file(s)...
Exception in thread "main" java.lang.ArrayIndexOutOfBoundsException: -23146894
        at io.gatling.charts.stats.buffers.CountsBuffer.update(CountBuffer.scala:35)
        at io.gatling.charts.stats.buffers.ResponsesPerSecBuffers$class.updateResponsesPerSecBuffers(ResponsesPerSecBuffers.scala:32)
        at io.gatling.charts.stats.ResultsHolder.updateResponsesPerSecBuffers(ResultsHolder.scala:21)
        at io.gatling.charts.stats.ResultsHolder.addRequestRecord(ResultsHolder.scala:48)
        at io.gatling.charts.stats.LogFileReader.io$gatling$charts$stats$LogFileReader$$$anonfun$10(LogFileReader.scala:150)
        at io.gatling.charts.stats.LogFileReader$lambda$$secondPass$1.apply(LogFileReader.scala:145)
        at io.gatling.charts.stats.LogFileReader$lambda$$secondPass$1.apply(LogFileReader.scala:145)
        at scala.collection.Iterator$class.foreach(Iterator.scala:893)
        at scala.collection.Iterator$ConcatIterator.foreach(Iterator.scala:168)
        at io.gatling.charts.stats.LogFileReader.secondPass(LogFileReader.scala:145)
        at io.gatling.charts.stats.LogFileReader.io$gatling$charts$stats$LogFileReader$$$anonfun$11(LogFileReader.scala:165)
        at io.gatling.charts.stats.LogFileReader$lambda$3.apply(LogFileReader.scala:165)
        at io.gatling.charts.stats.LogFileReader$lambda$3.apply(LogFileReader.scala:165)
        at io.gatling.charts.stats.LogFileReader.parseInputFiles(LogFileReader.scala:63)
        at io.gatling.charts.stats.LogFileReader.<init>(LogFileReader.scala:165)
        at io.gatling.app.LogFileProcessor.initLogFileReader(RunResultProcessor.scala:55)
        at io.gatling.app.LogFileProcessor.processRunResult(RunResultProcessor.scala:37)
        at io.gatling.app.Gatling.start(Gatling.scala:66)
        at io.gatling.app.Gatling$.start(Gatling.scala:57)
        at io.gatling.app.Gatling$.fromArgs(Gatling.scala:49)
        at io.gatling.app.Gatling$.main(Gatling.scala:43)
        at io.gatling.app.Gatling.main(Gatling.scala)

 I have no idea why.  Any suggestions?  I've been able to generate reports just fine in the past.

Paul Lanzerstorfer

unread,
Mar 20, 2017, 10:58:42 AM3/20/17
to Gatling User Group

Stéphane LANDELLE

unread,
Mar 20, 2017, 12:21:56 PM3/20/17
to gat...@googlegroups.com
Could you please provide a way to reproduce, eg a simulation.log?

Stéphane Landelle
GatlingCorp CEO


--
You received this message because you are subscribed to the Google Groups "Gatling User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to gatling+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Clint McGill

unread,
Mar 20, 2017, 1:10:59 PM3/20/17
to Gatling User Group
I'd love to, but I'm afraid I don't have those files any more.  If I encounter the error again, I'll post a followup.
To unsubscribe from this group and stop receiving emails from it, send an email to gatling+u...@googlegroups.com.

Stéphane LANDELLE

unread,
Mar 20, 2017, 4:13:22 PM3/20/17
to gat...@googlegroups.com
Thanks

Stéphane Landelle
GatlingCorp CEO


To unsubscribe from this group and stop receiving emails from it, send an email to gatling+unsubscribe@googlegroups.com.

Paul Lanzerstorfer

unread,
Mar 21, 2017, 4:42:44 AM3/21/17
to Gatling User Group
For me it happened with the attached file.
simulation.log

Stéphane LANDELLE

unread,
Mar 21, 2017, 4:52:13 AM3/21/17
to gat...@googlegroups.com
You sample works just fine for me (checked with both 2.2.4 and master).

Stéphane Landelle
GatlingCorp CEO


To unsubscribe from this group and stop receiving emails from it, send an email to gatling+unsubscribe@googlegroups.com.

Paul Lanzerstorfer

unread,
Mar 21, 2017, 6:13:10 AM3/21/17
to Gatling User Group
Grasping at straws here but my report would be generated on a Debian machine, could this be of interest for you?

Stéphane LANDELLE

unread,
Mar 21, 2017, 10:38:12 AM3/21/17
to gat...@googlegroups.com
I don't have a Debian, but I tested on OSX, Ubuntu and Fedora.
Anyway, I fail to see how such issue could be OS related.

I really suspect that don't have 2.2.3 nor 2.2.4 deployed but actually run an older version.

Stéphane Landelle
GatlingCorp CEO


To unsubscribe from this group and stop receiving emails from it, send an email to gatling+unsubscribe@googlegroups.com.

Paul Lanzerstorfer

unread,
Mar 22, 2017, 2:17:35 AM3/22/17
to Gatling User Group
My pom.xml references 2.2.4, I am using the maven plugin
<properties>
<maven.compiler.source>1.8</maven.compiler.source>
<maven.compiler.target>1.8</maven.compiler.target>
<scala.version>2.11.8</scala.version>
<encoding>UTF-8</encoding>

<gatling.version>2.2.4</gatling.version>
<gatling-plugin.version>2.2.4</gatling-plugin.version>

<scala-maven-plugin.version>3.2.2</scala-maven-plugin.version>
</properties>

<dependencyManagement>
<dependencies>
<dependency>
<groupId>io.gatling</groupId>
<artifactId>gatling-app</artifactId>
<version>${gatling.version}</version>
</dependency>
<dependency>
<groupId>io.gatling</groupId>
<artifactId>gatling-recorder</artifactId>
<version>${gatling.version}</version>
</dependency>
<dependency>
<groupId>io.gatling.highcharts</groupId>
<artifactId>gatling-charts-highcharts</artifactId>
<version>${gatling.version}</version>
</dependency>
<dependency>
<groupId>org.scala-lang</groupId>
<artifactId>scala-library</artifactId>
<version>${scala.version}</version>
</dependency>
</dependencies>
</dependencyManagement>

<dependencies>
<dependency>
<groupId>io.gatling.highcharts</groupId>
<artifactId>gatling-charts-highcharts</artifactId>
</dependency>
<dependency>
<groupId>io.gatling</groupId>
<artifactId>gatling-app</artifactId>
</dependency>
<dependency>
<groupId>io.gatling</groupId>
<artifactId>gatling-recorder</artifactId>
</dependency>
<dependency>
<groupId>org.scala-lang</groupId>
<artifactId>scala-library</artifactId>
</dependency>
</dependencies>

Stéphane LANDELLE

unread,
Mar 22, 2017, 5:21:31 AM3/22/17
to gat...@googlegroups.com
I guess Debian is actually your CI platform.
Have you checked that it indeed took the pom/gatling upgrade into account and that it's not actually running an old Gatling version?

Stéphane Landelle
GatlingCorp CEO


To unsubscribe from this group and stop receiving emails from it, send an email to gatling+unsubscribe@googlegroups.com.
Reply all
Reply to author
Forward
0 new messages