8 views
Skip to first unread message

cris

unread,
Dec 9, 2021, 2:16:14 PM12/9/21
to gasdot...@googlegroups.com
Ciao, ho un problema ad installare GASdotto localmente, mi serve una traccia per venirne fuori.

Potrebbe essere un problema di compatibilità tra PHP 8.0.13 e Symfony?
(Composer version 2.1.14)

Grazie, ciao.
Cristian


Cris-MacbookPro:~ cri5s$ cd /Applications/XAMPP/htdocs/GASdottoNG/code/

Cris-MacbookPro:code cri5s$ ls

HACK bootstrap config package.json resources storage webpack.mix.js

_docker build.sh database phpstan.neon routes test.sh

app composer.json dev.sh phpunit.xml run.sh tests

artisan composer.lock login.sh public server.php vendor

Cris-MacbookPro:code cri5s$ composer install

Installing dependencies from lock file (including require-dev)

Verifying lock file contents can be installed on current platform.

Nothing to install, update or remove

Package paypal/rest-api-sdk-php is abandoned, you should avoid using it. No replacement was suggested.

Package satispay/online-api-php-sdk is abandoned, you should avoid using it. Use satispay/gbusiness-api-php-sdk instead.

Package swiftmailer/swiftmailer is abandoned, you should avoid using it. Use symfony/mailer instead.

Generating optimized autoload files

> Illuminate\Foundation\ComposerScripts::postAutoloadDump

> @php artisan package:discover

PHP Fatal error:  Declaration of Xinax\LaravelGettext\FileLoader\Cache\ApcuFileCacheLoader::loadResource($resource) must be compatible with Symfony\Component\Translation\Loader\FileLoader::loadResource(string $resource): array in /Applications/XAMPP/xamppfiles/htdocs/GASdottoNG/code/vendor/zerospam/laravel-gettext/src/Xinax/LaravelGettext/FileLoader/Cache/ApcuFileCacheLoader.php on line 40


   Symfony\Component\ErrorHandler\Error\FatalError 


  Declaration of Xinax\LaravelGettext\FileLoader\Cache\ApcuFileCacheLoader::loadResource($resource) must be compatible with Symfony\Component\Translation\Loader\FileLoader::loadResource(string $resource): array


  at vendor/zerospam/laravel-gettext/src/Xinax/LaravelGettext/FileLoader/Cache/ApcuFileCacheLoader.php:40

     36▕      * @return array

     37▕      *

     38▕      * @throws InvalidResourceException if stream content has an invalid format

     39▕      */

    40    protected function loadResource($resource)

     41▕     {

     42▕         if (!extension_loaded('apcu')) {

     43▕             return $this->underlyingFileLoader->loadResource($resource);

     44▕         }



   Whoops\Exception\ErrorException 


  Declaration of Xinax\LaravelGettext\FileLoader\Cache\ApcuFileCacheLoader::loadResource($resource) must be compatible with Symfony\Component\Translation\Loader\FileLoader::loadResource(string $resource): array


  at vendor/zerospam/laravel-gettext/src/Xinax/LaravelGettext/FileLoader/Cache/ApcuFileCacheLoader.php:40

     36▕      * @return array

     37▕      *

     38▕      * @throws InvalidResourceException if stream content has an invalid format

     39▕      */

    40    protected function loadResource($resource)

     41▕     {

     42▕         if (!extension_loaded('apcu')) {

     43▕             return $this->underlyingFileLoader->loadResource($resource);

     44▕         }


      +1 vendor frames 

  2   [internal]:0

      Whoops\Run::handleShutdown()

Script @php artisan package:discover handling the post-autoload-dump event returned with error code 255

Cris-MacbookPro:code cri5s$ 



Cristian R.

Roberto Guido

unread,
Dec 10, 2021, 4:47:34 AM12/10/21
to gasdot...@googlegroups.com
On 09/12/21 20:16, cris wrote:
> Potrebbe essere un problema di compatibilità tra PHP 8.0.13 e Symfony?
> (Composer version 2.1.14)
>
Sicuramente c'e' qualche problema con PHP 8.0, non ho ancora provato il
porting.

E credo che quell'errore specifico lo dia anche su PHP 7.4: lo avevo
gia' notato, tra le mie cose da fare c'e' di mandare un fix al pacchetto
laravel-gettext (usato per le traduzioni)
https://github.com/zerospam/laravel-gettext/

Ti consiglio di usare PHP 7.3.

--
Roberto Guido
http://www.madbob.org/

Cristian Riccardi

unread,
Dec 13, 2021, 9:06:53 AM12/13/21
to gasdot...@googlegroups.com
Grazie, ora con PHP 7.3 la preparazione è andata a buon fine.

Purtroppo non funziona ancora, ma non vedo uno specifico errore nel verbose del development server, l’ambiente risponde, ma mi genera una pagina di errore e non entra nel popolamento del database e la configurazione iniziale.
Nel log vedo quando segue.

Secondo voi che verifica mi manca?

[2021-12-13 14:45:05] local.ERROR: Trying to get property 'message' of non-object (View: /Applications/XAMPP/xamppfiles/htdocs/GASdottoNG/code/resources/views/auth/login.blade.php) {"exception":"[object] (Illuminate\\View\\ViewException(code: 0): Trying to get property 'message' of non-object (View: /Applications/XAMPP/xamppfiles/htdocs/GASdottoNG/code/resources/views/auth/login.blade.php) at /Applications/XAMPP/xamppfiles/htdocs/GASdottoNG/code/storage/framework/views/f91c4cc6e3ce22c319db02f0267eacd6f3fdcb1c.php:4)
[stacktrace]
#0 /Applications/XAMPP/xamppfiles/htdocs/GASdottoNG/code/vendor/laravel/framework/src/Illuminate/View/Engines/PhpEngine.php(60): Illuminate\\View\\Engines\\CompilerEngine->handleViewException(Object(ErrorException), 1)

Grazie!

Ciao,
Cristian
______________


--
You received this message because you are subscribed to the Google Groups "GASdotto" group.
To unsubscribe from this group and stop receiving emails from it, send an email to gasdotto-dev...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/gasdotto-dev/4bcec9cc-3535-5914-852e-9a6ac27a86b5%40gmail.com.

Roberto Guido

unread,
Dec 13, 2021, 1:23:50 PM12/13/21
to gasdot...@googlegroups.com
On 13/12/21 15:06, Cristian Riccardi wrote:
> Purtroppo non funziona ancora, ma non vedo uno specifico errore nel
> verbose del development server, l’ambiente risponde, ma mi genera una
> pagina di errore e non entra nel popolamento del database e la
> configurazione iniziale.
>
Quasi sicuramente fallisce nel riconoscere il fatto che non e' ancora
stato inizializzato...

Ti invito ad eseguire a meno, nella root dell'applicazione (nel tuo
caso: /Applications/XAMPP/xamppfiles/htdocs/GASdottoNG/code/ ) i comandi:

php artisan key:generate
php artisan migrate
php artisan db:seed
php artisan db:seed --class=FirstInstallSeed

cris

unread,
Dec 14, 2021, 4:13:44 AM12/14/21
to gasdot...@googlegroups.com
Funziona, grazie!!!
Ho scaricato il db dalla istanza web e sostituito in locale, così posso fare qualche esperimento.
Ciao 👍


Cristian R.

--
You received this message because you are subscribed to the Google Groups "GASdotto" group.
To unsubscribe from this group and stop receiving emails from it, send an email to gasdotto-dev...@googlegroups.com.
Reply all
Reply to author
Forward
0 new messages