File input/output error

87 views
Skip to first unread message

Andrew Rosato

unread,
Jun 9, 2020, 7:08:33 AM6/9/20
to g_mmpbsa Mailing List
Hi All, 

I am attempting to run g_mmpbsa on a GROMACS MD simulation. I ran the command g_mmpbsa -f md_0_1.xtc -s md_0_1.tpr -n mmpbsa.ndx -i mmpbsa.mdp -pdie 2 -pbsa -decomp. I then selected my protein and ligand groups defined in my index file groups 18 and 19, respectively. The program seemed to be running through each frame of the MD simulation and generating this same error message at each step. It seems that I have incorrectly formated input data but I am unsure which of my files is the problem here and why. I am using the mdp file parameters provided in the github tutorial https://rashmikumari.github.io/g_mmpbsa/single_protein_ligand_binding_energy.html under the tests/wca_orig folder. Could you help me understand my error? Below is the error output message.


This executable compiled on May 13 2020 at 16:26:56

Parsing input file APp5TmETtA.in...
Parsed input file.
Reading parameter data from p5TmETt_param.dat.
asc_getToken: Error occurred (bailing out).
Vio_scanf: Format problem with input.
Got paths for 1 molecules

WARNING!!  Radius/charge information from PQR file p5TmETtA.pqr
will be replaced with data from parameter file (p5TmETt_param.dat)!
Reading PQR-format atom data from p5TmETtA.pqr.
Vparam_getAtomData:  unable to find atom 'O1', res 'TRP'
Valist_readPDB:  Couldn't find parameters for atom = O1, residue = TRP
Error reading molecules!

-------------------------------------------------------
Program g_mmpbsa, VERSION 5.1.5
Source code file: /dev/shm/spack/stage/jchits/spack-stage-gromacs-5.1.5-uqmkecg5de33mbf6xvvnvs67alsf3mpv/spack-src/src/gromacs/utility/futil.cpp, line: 469

File input/output error:
p5TmETtA.pqr

g_mmpbsa Mailing List

unread,
Jun 9, 2020, 7:17:34 AM6/9/20
to g_mmpbsa Mailing List

It seems there is mismatch between pqr and *param.dat file. Do you really need WCA in the calculation. According to the g_mmpbsa publication, it does not improves the correlation and significantly increases mean absolute error. I have seen this error for some system in forum, but I do not have test cases to reproduce them. Furthermore, we authors are not currently in a situation to test and modify the code due to the time constraint.

Andrew Rosato

unread,
Jun 9, 2020, 12:27:04 PM6/9/20
to g_mmpbsa Mailing List
Thank you for the suggestion! 

After setting the use WCA parameter to "no" in my mdp file the program was able to run to completion without errors. 

Best, 
Andrew

Andrew Rosato

unread,
Jun 14, 2020, 1:27:57 PM6/14/20
to g_mmpbsa Mailing List
It seems that the WCA method was partially the source of the errors being generated here. After setting the use WCA parameter to "no" in my mdp file the program was able to run to completion without errors. While the calculation ran to completion and the polar.xvg file correctly populated with values, the values of the apolar.xvg file were all zero. Do you have any idea why that might be?

Best, 
Andrew
Reply all
Reply to author
Forward
0 new messages