FusionDebug startup error

Skip to first unread message

Jensen, Darren W. (GE, Corporate)

Apr 25, 2011, 10:49:59 AM4/25/11
to fusio...@googlegroups.com

I get the following error when trying to launch the debugger in eclipse.




java.vendor=Sun Microsystems Inc.

BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US

Framework arguments:  -product org.eclipse.epp.package.jee.product

Command-line arguments:  -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.jee.product




Thu Apr 21 22:47:47 EDT 2011

Couldn't launch a debug session: null



at com.intergral.fusiondebug.api.driver.ui.preferences.C.C(CFDBExtensionManager.java:83)

at com.intergral.fusiondebug.api.driver.core.FDDebugTarget.supportsBreakpointInternal(FDDebugTarget.java:631)

at com.intergral.fusiondebug.api.driver.core.FDDebugTarget.supportsBreakpoint(FDDebugTarget.java:648)

at com.intergral.fusiondebug.api.driver.core.FDDebugTarget.breakpointAdded(FDDebugTarget.java:909)

at com.intergral.fusiondebug.api.driver.core.FDDebugTarget.R(FDDebugTarget.java:518)

at com.intergral.fusiondebug.api.driver.core.FDDebugTarget.<init>(FDDebugTarget.java:428)

at com.intergral.fusiondebug.api.driver.core.launching.FDLaunchDelegate.launch(FDLaunchDelegate.java:62)

at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:853)

at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:702)

at org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(DebugUIPlugin.java:924)

at org.eclipse.debug.internal.ui.DebugUIPlugin$8.run(DebugUIPlugin.java:1128)

at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)


Here are the jvm config args:


-Dprogram.name=run.bat -Djava.endorsed.dirs="C:/jboss/jboss-as/bin/../lib/endorsed" -Xms128m -Xmx512m -XX:MaxPermSize=128m -Djava.compiler=NONE -Xnoagent -Xdebug -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=8000


Server is JBoss 4.3.0, launched within eclipse.  No port conflicts.  I tried 8001 and 8011 and received same error.


I setup fusionDebug with the eclipse installer and had no issues.  I had this working on an older laptop.  But I cannot get this to work on a new laptop with newer eclipse, newer jvm and new fusionDebug version.  I compared old setup to new setup to try and troubleshoot, but that did not help.


Any idea what may be going on at the point of failure at line 83 in class above?





Darren Pywell [FusionDebug Team]

Apr 25, 2011, 11:04:40 AM4/25/11
to FusionDebug
Looks to me like the configuration for FD has a problem somehow. Can
you check that in Eclipse Window->Preferences->FusionDebug that the
prefs are Configuration and License are ok?


On Apr 25, 4:49 pm, "Jensen, Darren W. (GE, Corporate)"


Apr 25, 2011, 11:47:33 AM4/25/11
to FusionDebug
Under Window->Preferences->FusionDebug, I do have Configuration and
License sub nodes.

For Configuration I have in the Extensions field
".cfm, .cfml, .cfc, .htm, .html" and in the two auto-step fields "100"

For License, it says "This license has been activitated", with the
license info displayed above. The Edition says "Subscription Updates
until Thu 27 00:00:00 CET 2011". So, I'm not sure if that is an

Is it having difficult reading these preferences or with understanding
the preferences?


On Apr 25, 11:04 am, "Darren Pywell [FusionDebug Team]"
> > Thanks- Hide quoted text -
> - Show quoted text -

Darren Pywell [FusionDebug Team]

Apr 25, 2011, 11:59:07 AM4/25/11
to FusionDebug
I just wanted to check that it can read the configuration. Can you try
changing the the two auto step values to 200 and saving the
configuration; perhaps there is an issue in writing to the
configuration file.


Darren Pywell [FusionDebug Team]

Apr 25, 2011, 12:10:37 PM4/25/11
to FusionDebug
That spot in the code is looking at the extensions to test for
debugging. It would seem that the extension that is been tested is
null. Somehow it looks like the debugger has fired on a file without
an extension?!? Could it be that a breakpoint is in a file with no


On Apr 25, 5:47 pm, coldAir <darren.jen...@ge.com> wrote:


Apr 25, 2011, 12:22:37 PM4/25/11
to FusionDebug
That was it. I checked the "All Breakpoints" view and found the first
entry did not contain point to a file. The entry generated errors
when I clicked on it. I was able to remove the corrupt breakpoint
from the list. After doing so, FD started up fine.

Thanks for the great support. Debugging is a critical function I
cannot do without.

On Apr 25, 12:10 pm, "Darren Pywell [FusionDebug Team]"
> > > - Show quoted text -- Hide quoted text -
Reply all
Reply to author
0 new messages