FriCAS in Sage

23 views
Skip to first unread message

Ralf Hemmecke

unread,
Sep 26, 2017, 6:29:15 PM9/26/17
to fricas-devel
Interesting. There are voices to make FriCAS an optional package in Sage.

https://groups.google.com/forum/#!topic/sage-devel/cHkVjFt1pIY

Ralf

oldk1331

unread,
Sep 26, 2017, 7:37:18 PM9/26/17
to fricas-devel
Glad to see Martin Rubey is still interested in FriCAS.

Martin R

unread,
Sep 27, 2017, 1:21:07 AM9/27/17
to FriCAS - computer algebra system
Hi there,

To clarify: FriCAS *was* an optional package for a long time.  It was downgraded to "experimental" because some doctests of the interface to sage didn't work at a specific time, and all packages having this problem were treated like that.

The difference between "experimental" and "optional" is that changes within sage must not break the interface of optional packages, which helps maintaining.

Help is, of course, always appreciated.  In particular in improving the interface - most importantly, the communication between sage and FriCAS is still via files, and should be done as described in https://groups.google.com/forum/#!topic/fricas-devel/qYzrY-92Q2A

(even a working proof of concept would be very helpful)

Martin

Martin R

unread,
Sep 27, 2017, 9:25:24 AM9/27/17
to FriCAS - computer algebra system
Help needed!

to make fricas optional, I need to know:

* does FriCAS (the tarball from sourceforge) build on various architectures and systems (32bits/64 bits, GNULinux/cygwin/OSX)

* how do I invoke the testsuite?

Martin

Martin R

unread,
Sep 27, 2017, 9:29:29 AM9/27/17
to FriCAS - computer algebra system
apparently I need:

* Linux
* Mac OS X
* Solaris SPARC 32-bit

Martin

oldk1331

unread,
Sep 27, 2017, 10:27:27 AM9/27/17
to fricas-devel
FriCAS builds on 32/64 bit Linux, 64 bit OSX (there's no 32 bit OSX anymore),
should build on 32 bits cygwin (it's not been built for a long time),
not sure about
64bit cygwin.

You can invoke the testsuite by "cd src/input && make", although there's no
script to collect the results, there's an unofficial one:

https://raw.githubusercontent.com/oldk1331/fricas/116f64b1fea32b7148421a4efb43117cf3eee819/src/scripts/test.sh

Is "Solaris SPARC 32-bit" needed? That seems to be very old.
axiom_20120501 builds on SPARC Debian, so I guess FriCAS would
compile, but I don't think anyone tried.
Reply all
Reply to author
Forward
0 new messages