Installing only fricas script

0 views
Skip to first unread message

Waldek Hebisch

unread,
Feb 19, 2009, 5:09:14 PM2/19/09
to fricas...@googlegroups.com
The patch below changes Makefile to no longer install 'axiom' script.
This should remove remainig incompatibility with Tim Daly Axiom.

I proposed this change more than year ago, but at that time there
were concerns that it will create trouble for external software.
However, for more than year we install 'fricas' script and
IMHO this is enough time for others to adapt software.

FYI, the old tread is at:

http://groups.google.com/group/fricas-devel/browse_thread/thread/34f21f3a07453a59

Potentially affected external software mentioned in that thread
includes:

- FriCAS mode for Emacs
- Sage interface
- Texmas interface
- Media Wiki interface

IIUC the last two use AXIOMsys directly, so in fact the change
below does not affect them. FriCAS mode was adjusted for some
time and there is now proposed patch to adjust Sage interface.
So I think there is no more reason postpone the change.

--- ../trunk/Makefile.in 2009-02-19 15:04:37.000000000 -0500
+++ trunk/Makefile.in 2009-02-19 20:09:16.000000000 -0500
@@ -159,7 +159,6 @@
rm -f '$(DESTDIR)$(bindir)'/fricas
$(mkinstalldirs) '$(DESTDIR)$(bindir)'
$(INSTALL_SCRIPT) '$(COMMAND)' '$(DESTDIR)$(bindir)/fricas'
- $(INSTALL_SCRIPT) '$(COMMAND)' '$(DESTDIR)$(bindir)/axiom'
if test -n "@BUILD_ALDOR_INTERFACE@"; then \
cd src/aldor && $(MAKE) install; \
fi

--
Waldek Hebisch
heb...@math.uni.wroc.pl

Martin Rubey

unread,
Feb 20, 2009, 2:45:35 AM2/20/09
to fricas...@googlegroups.com
Waldek Hebisch <heb...@math.uni.wroc.pl> writes:

> The patch below changes Makefile to no longer install 'axiom' script.
> This should remove remainig incompatibility with Tim Daly Axiom.

Go for it.

Martin

Reply all
Reply to author
Forward
0 new messages