Frescobaldi crash on Ubuntu 22.04 LTS

Skip to first unread message

May 21, 2022, 11:25:27 AM5/21/22
to Frescobaldi
Greetings -

I recently upgraded my Ubuntu to 22.04 LTS. It was complicated, and I couldn't transfer Frescobaldi or LilyPond directly.

When I downloaded Frescobaldi through the default applications link, it installed Version 3.1.3+ds1. When I tried to open Frescobaldi, I got the following message :


Traceback (most recent call last):

File "/usr/share/frescobaldi/frescobaldi_app/widgets/", line 83, in paintEvent


TypeError: moveTop(self, int): argument 1 has unexpected type 'float'


I saw online that it might work better to use flatPak, so I installed flatPak and the Gnome applications software. I reinstalled Frescobaldi, and it was the same version with the same error message.

I would appreciate any help you can give me. I depend on Frescobaldi, and greatly appreciate its functionality.

All the best,


Ralph Palmer

Seattle, WA, USA

Federico Bruni

May 22, 2022, 1:46:36 AM5/22/22
to, Frescobaldi
Are you sure you ran Frescobaldi flatpak? You must run it from the terminal if you also have the regular ubuntu package installed.

flatpak run org.frescobaldi.Frescobaldi

I haven't used it for a while so I don't know if runtime python changed recently.

Kevin Cole

May 22, 2022, 7:13:15 AM5/22/22
to Frescobaldi

I ran into this as well, basically got the feedback "don't use the .deb package". (The problem arises from an upgrade to Python 3.10.)

Ultimately, I ended up having to:

$ sudo apt purge frescobaldi

$ pip install --user qpageview
$ cd frescobaldi-3.2
$ python3 install --user

This installs everything locally in your ~/.local/lib/python3.10/site-packages/ directory.

Also, because Ubuntu dpkg no longer knows about Frescobaldi after the above, it happily wants to remove "unused" packages. Unfortunately, they're not unused.  Purging them and installing them manually lets dpkg know they're important and installed explicitly by you:

$ sudo apt purge   python3-ly python3-poppler-qt5 python3-pygame tango-icon-theme
$ sudo apt install python3-ly python3-poppler-qt5 python3-pygame tango-icon-theme

(I think apt install --reinstall would have eliminated the need for the apt purge. But the above is what I did and it worked for me.)

Ralph Palmer

May 24, 2022, 10:24:31 AM5/24/22
to Federico Bruni, Frescobaldi
I'm still having problems. I'd like to start over from scratch, but I can't find any instructions for uninstalling Frescobaldi. I did run Frescobaldi flatpak.

I tried uninstalling from terminal, with no luck. I then tried
sudo apt purge frescobaldi
but got the message :
Package 'frescobaldi' is not installed, so not removed
with a list of packages "no longer required" and
Use 'sudo apt autoremove' to remove them.
I ran
sudo apt autoremove
and Frescobaldi no longer launches, either from terminal or from Applications, although the Frescobaldi logo is still in Applications.
Also, my Home directory still has a
frescobaldi-3.2       folder, with 24 items, and

Can someone please advise me as to how to proceed? Just delete the frescobaldi-3.2 folder and start from scratch?

I appreciate any help I can get.

All the best,


Ralph Palmer
(he, him, his)

Federico Bruni

May 24, 2022, 5:46:20 PM5/24/22
to Ralph Palmer, Frescobaldi
On Tue, May 24 2022 at 07:24:18 -0700, Ralph Palmer
<> wrote:
> I'm still having problems. I'd like to start over from scratch, but I
> can't find any instructions for uninstalling Frescobaldi. I did run
> Frescobaldi flatpak.

Current Frescobaldi flatpak (still on version 3.1.3 due to a problem
with a Sdk dependency) is using python 3.8 so you shouldn't have any
problem. It's working fine here.

Frescobaldi flatpak is using these versions (Help>About
Frescobaldi>Version menu):

Frescobaldi: 3.1.3
Extension API: 0.9.0
Python: 3.8.12
python-ly: 0.9.7
Qt: 5.15.3
PyQt: 5.15.2
sip: 4.19.24
poppler: 21.6.1
python-poppler-qt: 0.75.0
OS: Linux-5.17.7-300.fc36.x86_64-x86_64-with-glibc2.2.5

If you see something different, you are not running Frescobaldi flatpak.

Ralph Palmer

May 24, 2022, 9:57:17 PM5/24/22
to Federico Bruni, Frescobaldi
Thanks, Federico -

This all started, I believe, with the technician who reorganized my laptop. He reset the laptop to a blank Ubuntu 22.04 with a new single username, and when I did a full restore from my backups, I ran into a lot of conflicts due to the change in username. They've agreed to quickly restore to a blank Ubuntu with my previous username, and I'll try another restore, then go from there. I still want to move to the newer Frescobaldi and the current unstable LilyPond release.

All the best,

Reply all
Reply to author
0 new messages