LLRP Commander - create remote adaptor connection refused to host

34 views
Skip to first unread message

Marcus Gomes

unread,
Jul 30, 2015, 7:40:27 AM7/30/15
to fosstrak
Hello guys,

I am trying to create a LLRP remote adapter with LLRP Commander. My LLRP Commander is running in a local machine while my ALE is running in a cloud server (AWS EC2). However, when I tried to create the remote adapter "Add Adapter Instance -> IP = Public Server IP -> OK". However, instead of to create the remote adapter I get the following exception in LLRP Commander: 

"Connection refused to host: Private Server IP; nested exception is: java.net.ConnectException: Connection timed out". 

Initially I think that my firewall was blocking the incoming connection, but I made a test by opening all ports and I still get the same exception. After that I figure out that the problem maybe is related with Java, namely the java parameters options that are passed to the application, so I update the CATALINA_OPTS with:

export CATALINA_OPTS="-Dcom.sun.management.jmxremote
                                            -Dcom.sun.management.jmxremote.authenticate=false
                                            -Dcom.sun.management.jmxremote.ssl=false
                                            -Djava.rmi.server.hostname=my.public.ip"

But this not fixed my problem and I still get the same exception when I try to create a remote adaptor. Can you help me fix that issue?

Marcus Gomes

unread,
Jul 30, 2015, 4:14:24 PM7/30/15
to fosstrak, mvp.go...@gmail.com
Problem solved, I was passing the public instance IP instead of the instance Public DNS to the CATALINA_OPTS environment variable.
Reply all
Reply to author
Forward
0 new messages