[Update] Flutter 3.13.4

1,316 views
Skip to first unread message

Kevin Chisholm

unread,
Sep 13, 2023, 5:28:10 PM9/13/23
to Flutter Public Announcements (flutter-announce)

We are pleased to announce the release of Flutter 3.13.4 to the stable channel; This hotfix release addresses the following issues:

  • dart/53449 - Fixes a dart2js issue causing a compiler crash when using a typed record pattern outside of the scope of a function body.
  • dart/53450 - Fixes a pause in the debugger when reaching an unhandled exception.
  • flutter/133658 - Fixes crash when using the --analyze-size argument.
  • flutter/133890 - Fixes incorrect autocorrect highlights in text fields in iOS 17.
  • flutter/134468 - Fixes an issue where users are not able to input text for IME language in iOS 17.
  • flutter/45742 - Fixes CVE-2023-4863 - Security vulnerability in WebP.
Applications that show images chosen by users may wish to upgrade to avoid a potential remote code execution attack that exists prior to the fix for CVE-2023-4863.

In order to get the latest, run ‘flutter upgrade’.

Reply all
Reply to author
Forward
0 new messages