Can't get IPv6 configuration to work

43 views
Skip to first unread message

Scott Alfter

unread,
Oct 5, 2021, 8:46:14 AM10/5/21
to Flatcar Container Linux User
I've deployed Flatcar to a Linode VPS, more or less following this
guide I knocked together to get the QEMU variant running:

https://alfter.us/2021/09/20/installing-flatcar-container-linux-on-linode/

IPv4 works properly, but it doesn't auto-configure IPv6 properly.
It looks like DHCPv6 is failing at its job.

Linode has this page on static IP configuration that covers IPv6 and
includes a sample /etc/systemd/network/eth0.network for CoreOS:

https://www.linode.com/docs/guides/linux-static-ip-configuration/

I plugged in the address and gateway information, but I still can't get
IPv6 working. It contains the following:

------------------------------ start ------------------------------
[Match]
Name=eth0

[Network]
DHCP=no
Domains=members.linode.com
IPv6PrivacyExtensions=false

# DNS resolvers (safe to mix IPv4 and IPv6)
DNS=96.126.122.5 96.126.124.5 96.126.127.5

# IPv4 gateway and primary address.
Gateway=45.79.5.1
Address=45.79.5.166/24

# Add a second public IPv4 address.
#Address=198.51.100.3/24

# Add a private address:
#Address=192.168.133.234/17

# IPv6 gateway and primary address.
Gateway=fe80::1
Address=2600:3c00::f03c:92ff:fea5:9101/64

# Add a second IPv6 address.
#Address=2001:db8:2000:aff0::3/64
------------------------------- end -------------------------------

I've tried setting it manually:

ifconfig eth0 inet6 add 2600:3c00::f03c:92ff:fea5:9101/64

This sets the address on the interface, but (1) this will be lost on
the next reboot and (2) it's still not passing traffic when I try to
ping from or to it. Is there something I'm doing wrong, or
(hopefully unlikely) does Flatcar not support IPv6?

FWIW, I also have a bare-metal Flatcar setup on a home server, and
noticed that it's not speaking IPv6 either. The network configuration
on that is the default, in which DHCP is setting it up for IPv4, but
fails to set up IPv6. IPv6 works just fine on the rest of my home
network, with a mix of Gentoo Linux and Windows 10 clients and an
OpenWRT router (on a Raspberry Pi Compute Module 4).

Scott Alfter
sc...@alfter.us
Message has been deleted

vin...@kinvolk.io

unread,
Oct 15, 2021, 9:24:00 AM10/15/21
to Flatcar Container Linux User
Hey Scott,

It looks like the response to this message got flagged as spam 🤦.
Jeremi (jepio) said:

Hi Scott,

IPv6 broke during a stable upgrade of systemd. Sayan is working on a
fix https://github.com/flatcar-linux/init/pull/51.
Reply all
Reply to author
Forward
0 new messages