installing fireshark on Ubuntu 11.04

142 views
Skip to first unread message

Stephan

unread,
May 31, 2011, 8:47:24 PM5/31/11
to fireshark
so a few of you said you had issues installing Fireshark on Ubuntu
11.04, so I intalled it on VirtualBox today, here are my notes:

I came across a bunch of errors when installing perl 5.12 that I
hadn't come across in earlier installations of Ubuntu.

A Google search for:
"undefined reference to 'fmod' perl 5.12 11.04"
showed me why.

My suggestion is installing perl 5.14 which was released mid-May
2011.
That worked for me.
after that, I cd'd to the bin dir of fireshark and ran the ./
list.modules and ./test.modules to install the perl dependancies

did have some issues installing certain perl dependencies like
GraphViz, and Proc::ProcessTable so I had to install those manually,
For GraphViz I downloaded the gzip tar'd file and installed it
normally for Proc::ProcessTable I couldn't go through CPAN so I
installed it using the package manager: e.g. sudo apt-get install
libproc-processtable-perl

After painfully installing all the dependencies (tedious!) I ran ./
test.modules and it showed me that i had all the modules installed
correctly.

I did get a socket error when attempting to go to /home/fireshark/
testFireshark.pl but after waiting a minute the socket was free and I
started the service by issuing the following commands
sudo killall fireshark
sudo /etc/init.d/fireshark start

to verify the service is running...
pgrep fireshark

if all else fails read the README file and there is a section at the
bottom for trouble shooting...
Stephan
Reply all
Reply to author
Forward
0 new messages