Can't load INTL module '/usr/lib64/firebird/intl/fbintl.so'

28 views
Skip to first unread message

Jan Maxa

unread,
Nov 20, 2019, 1:53:19 PM11/20/19
to Firebird (CZ)
Dobrý den,
potřeboval bych poradit, jak nejlépe vyřešit chybu " Can't load INTL module '/usr/lib64/firebird/intl/fbintl.so' ".
Tato chyba se mi objevila v logu firebird po instalaci navrhovaných update pro Centos 7.7
V rámci této dávky update se mimo jiné provedla aktualizace z firebird-2.5.7.27050.0-1.el7.x86_64 na firebird-2.5.9.27139.0-1.el7.x86_64.
Po restartu serveru se do logu firebirdu začala několikanásobně vypisovat chyba Can't load INTL module '/usr/lib64/firebird/intl/fbintl.so'
a nebylo možné pracovat s tabulkami, které obsahují sloupečky s kódování WIN1250.

Velmi podobný problém je popsán v http://tracker.firebirdsql.org/browse/CORE-5925
takže jsem použil stejný workaround a přepsal jsem  /usr/lib64/firebird/intl/fbintl verzí z firebird-2.5.7.27050.
Databáze nyní běží, ale nejsem si jist, zdali to nemůže způsobit nějaké problémy do budoucna.

Můžete mi prosím poradit, jak nejlépe tento problém vyřešit ?
Původně jsem chtěl provést reinstalaci na původní verzi firebird-2.5.7.27050, ale to se mi bohužel nedaří.

Předem děkuji za rady

Jiří Činčura

unread,
Nov 20, 2019, 1:55:13 PM11/20/19
to fireb...@googlegroups.com
> Můžete mi prosím poradit, jak nejlépe tento problém vyřešit ?

Instalovat z oficialniho baliku z firebirdsql.org.

> Původně jsem chtěl provést reinstalaci na původní verzi
> firebird-2.5.7.27050, ale to se mi bohužel nedaří.

To je samozrejme hloupost. Provozovat starou verzi jakehokoli SW je nerozum.

--
Mgr. Jiří Činčura
https://www.tabsoverspaces.com/

Reply all
Reply to author
Forward
0 new messages