Jaybird 4.0.2 and 3.0.10 released

1 view
Skip to first unread message

Mark Rotteveel

unread,
Jan 17, 2021, 8:11:07 AMJan 17
to firebi...@googlegroups.com, firebird...@googlegroups.com

Jaybird 4.0.2 and 3.0.10 have been released.

Jaybird 4.0.2

The following has been changed or fixed since Jaybird 4.0.1:

  • Fixed: First letter of JDBC escape was case-sensitive (JDBC-632)

  • Fixed: Some usernames cannot authenticate using SRP (JDBC-635)

  • Fixed: ServiceConfigurationError while loading plugins could prevent Jaybird from loading (JDBC-636)

Jaybird 4 supports Firebird 2.5 and higher, on Java 7, 8, 11 and 15 (support for Java 15 using the Java 11 version of the driver).

See also:

Jaybird 3.0.10

Although Jaybird 3 is still maintained, we recommend upgrading to Jaybird 4.

The following has been changed or fixed since Jaybird 3.0.10:

  • Added: A static utility method FBDriver.normalizeProperties which, given a JDBC url and a Properties object, returns a Map<String, String> containing the merged properties normalized to the common property name. (JDBC-627)

  • Fixed: Use of isc_dpb_no_db_triggers no longer logs a warning (JDBC-628)

  • Fixed: First letter of JDBC escape was case-sensitive (JDBC-632)

  • Fixed: Some usernames cannot authenticate using SRP (JDBC-635)

  • Fixed: ServiceConfigurationError while loading plugins could prevent Jaybird from loading (JDBC-636)

Jaybird 3 supports Firebird 2.0 and higher, on Java 7, 8, 11 and 15. Basic Java 9 and higher compatibility is provided through the Java 8 version of the driver.

See also:

-- 
Mark Rotteveel
Reply all
Reply to author
Forward
0 new messages