Site not found on doing firebase deploy

185 views
Skip to first unread message

LAVISH

unread,
May 6, 2024, 6:55:23 PMMay 6
to Firebase Google Group
I deployed my website on Firebase earlier, and it worked fine. But, some days back, when I looked at it, it showed a Site Not Found Error.



I tried many ways to resolve it, but none of them worked.

  1. I tried to log out and then log in again in Firebase CLI and then redeployed, but it shows the same screen.
  2. Whenever I am doing npm start or serve -s build, it is running completely fine on localhost, but on running firebase hosting:channel:deploy to run my web app on the beta channel, it is still showing the same error.

I asked this question on Stack Overflow, but it got closed, saying, "This question needs debugging details. It is not currently accepting answers." I do not know what code would be required to present a Minimal Reproducible Example and what mistake I am making. If someone can help me with this, I would highly appreciate it.

Thanking you,
Lavish

Milan Chabhadiya

unread,
May 14, 2024, 12:03:06 PMMay 14
to Firebase Google Group
I'm also encountering a "Site Not Found" error with Firebase deployment. That's frustrating! It suddenly starts showing the error after successful deployment. Now, if I create a new website in Firebase Hosting, then it starts working correctly. However, I'm unable to redeploy the build on my previous website, and it continues to show the "Site Not Found" error.


Just wanted to check in and see if you've managed to resolve the issue on your end. If you found a solution, I'd be grateful if you could share it. It might help others facing a similar problem.

Thank you,
Milan Chabhadiya

LAVISH

unread,
May 23, 2024, 10:16:46 AMMay 23
to Firebase Google Group
No Milan, I have not found any solution for this problem and I am continuously searching for its solution.

Milan Chabhadiya

unread,
May 25, 2024, 11:10:05 AMMay 25
to fireba...@googlegroups.com

Hi Lavish,

My issue was resolved after a week. The Firebase team reviewed my project, confirmed it complies with the privacy policy, and reinstated it. The "site not found" problem was because I was using an HTTP (non-SSL) URL for API calls. After their review, my website is back up and running.

Thanks!


--
You received this message because you are subscribed to a topic in the Google Groups "Firebase Google Group" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/firebase-talk/g5fnkw4woXg/unsubscribe.
To unsubscribe from this group and all its topics, send an email to firebase-tal...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/firebase-talk/7624158d-f5df-46b8-bf3c-b4a4b126db4an%40googlegroups.com.
Reply all
Reply to author
Forward
0 new messages