Latest Mac OS X Java update breaks BEAST/Tracer/FigTree

1195 views
Skip to first unread message

Andrew Rambaut

unread,
Jun 21, 2013, 9:17:38 AM6/21/13
to beast...@googlegroups.com, FigTree Discussion, figtree-...@googlegroups.com
Dear all,

This is a warning that the latest update to Java for Mac OS X released yesterday ('Java for
OS X 2013-004') will stop the current version of most of the GUI versions of programs in the
BEAST/FigTree family from working. This includes BEAUti, BEAST, FigTree, Tracer etc.

The fix is relatively straight forward but it will take a few days to test everything
and package it all up. In the meantime, you may want to consider holding off from installing
this update. The update fixes some security issues with using the Java Applet plugin for
web browsers which is something that is probably not a good idea to use anyway.

The issue is derived from the programs using a technically incorrect way of initialising
the user interface that up until this point has worked fine. It is possible therefore
that this issue could occur on other platforms in future so all versions will be updated.

Thanks,
Andrew


___________________________________________________________________
Andrew Rambaut
Institute of Evolutionary Biology University of Edinburgh
Ashworth Laboratories Edinburgh EH9 3JT
EMAIL - a.ra...@ed.ac.uk TEL - +44 131 6508624


--
The University of Edinburgh is a charitable body, registered in
Scotland, with registration number SC005336.

Andrew Rambaut

unread,
Jun 21, 2013, 5:47:38 PM6/21/13
to beast...@googlegroups.com, FigTree Discussion, figtree-...@googlegroups.com
Dear All,

Please ignore if you are not using Mac OS X.

It appears Apple have corrected their revision to fix this issue. If you update now then
FigTree, Tracer, BEAST will work. If you have updated Java earlier today or yesterday
then you will need to download the new updater and install it.

To check if you have the newer or older (broken) update, open Terminal.app and type:

java -version

If you see this number:

build 1.6.0_51-b11-457-11M4509

You have the new and working version. If you see '4508' at the end of this number then you
have the older version and you need to re-update the update.

Download the update from here (but only if you see 4508 in the version number):

http://support.apple.com/kb/DL1572

Andrew
Reply all
Reply to author
Forward
0 new messages