Feedburner Not Returning XML

36 views
Skip to first unread message

Web Team

unread,
Sep 12, 2022, 10:44:25 AM9/12/22
to FeedBurner Help Group
Recently had an issue ONE of my podcasts had a source URL which was returning a 404:

I updated the source URL.

And now it's returning text at https://feeds2.feedburner.com/insurancelaw instead of XML, but the source data is XML.

Can you please advise?

Thanks,
John

Brian Walker

unread,
Sep 12, 2022, 10:53:23 AM9/12/22
to FeedBurner Help Group
Please used just feeds.feedburner.com instead of feeds2.feedburner.com. Also, your feed is returning xml, FeedBurner no longer creates and attaches a stylesheet to your rss feed. This can cause it to render as just a wall of text. However, this doesn't affect how it is ingested in third party aggregators or podcatchers, it is just the way browsers will display it without a stylesheet or with a stylesheet it can't access. Some attached stylesheets will cause an error because they are coming from a domain that doesn't match the domain serving the feed. This is a security feature to prevent running scripts that originated in a different domain than the one serving the feed.  

Web Team

unread,
Sep 12, 2022, 11:05:42 AM9/12/22
to FeedBurner Help Group
OK - but it doesnt have the latest info despite a few manual refreshes.

Web Team

unread,
Sep 12, 2022, 11:10:20 AM9/12/22
to FeedBurner Help Group
let me clarify if i type that url manually as an XML into google podcast app, it only gives me the podcast from july 2021, it doesnt match whats being returned on the browser.

Brian Walker

unread,
Sep 12, 2022, 11:30:28 AM9/12/22
to FeedBurner Help Group
I would recommended reaching out to the Google Podcasts team.  This doesn't look like a FeedBurner issue.  The xml being returned is the same everywhere, whether you type it into Google Podcasts or through the browser. Our database only has one version of the data for any given feed. The xml being returned and stored by FeedBurner has the newest entry as August 31st, 2022. I'm not sure why Google Podcasts would be showing something different. 

Web Team

unread,
Sep 12, 2022, 12:09:47 PM9/12/22
to FeedBurner Help Group
It was old/cached data.  It's not working because all the tags are stripped out.  I've tried other rss readers and get problems too.

Why are the tags stripped out?

Message has been deleted

Brian Walker

unread,
Sep 12, 2022, 12:35:28 PM9/12/22
to FeedBurner Help Group
I'm not sure what you mean. We don't strip any tags.  If you are looking at this in a browser, it will appear as text. That is not how it is being returned from FeedBurner it is just how the browser displays it. You can see the actual response in the browser developer tools menu. 

6Cd2BumyddhHkbb.png

The left is what the browser is rendering, which is just text. The right is the actual elements returned from the FeedBurner response. You can see all the RSS tags are present.
Reply all
Reply to author
Forward
0 new messages